summaryrefslogtreecommitdiff
path: root/packages/ftpd-topfield/ftpd-topfield_0.7.5.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-03-28 16:04:12 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-03-28 16:04:12 +0000
commitf54bd12991023b60209135e7e77b86afa2b80b76 (patch)
treeb97769d104766c213609b5f7bc6c7fb514a2909a /packages/ftpd-topfield/ftpd-topfield_0.7.5.bb
parenta61d0ff5bdb2c9006f5e35d70cea3f74f66231d1 (diff)
parentaae834760ee0eb60cfa60353ad09c6b6431acee4 (diff)
merge of '9fdf613358c5efcdb75a30ee08729a9e2a7ade08'
and 'ee2aa51c8eb93fa5579f4cf49a53eb0cb3e90319'
Diffstat (limited to 'packages/ftpd-topfield/ftpd-topfield_0.7.5.bb')
-rwxr-xr-xpackages/ftpd-topfield/ftpd-topfield_0.7.5.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/ftpd-topfield/ftpd-topfield_0.7.5.bb b/packages/ftpd-topfield/ftpd-topfield_0.7.5.bb
new file mode 100755
index 0000000000..74a3743b1e
--- /dev/null
+++ b/packages/ftpd-topfield/ftpd-topfield_0.7.5.bb
@@ -0,0 +1,34 @@
+# This package builds the ftpd-topfield program
+DESCRIPTION = "ftpd-topfield - FTP access to TopField PVR"
+HOMEPAGE = "http://sourceforge.net/projects/puppy"
+SECTION = "net"
+LICENSE = "MIT"
+PR = "r1"
+
+SRC_URI = "cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_7_5 \
+ cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_7_5 \
+ file://syslog.patch;patch=1 \
+ file://init"
+
+# The source will end up in the subdirectory 'ftpd-topfield' - no release name
+S = "${WORKDIR}/ftpd-topfield"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "ftpd-topfield"
+INITSCRIPT_PARAMS = "defaults"
+
+# Just the one package at present
+
+inherit autotools
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/ftpd ${D}${sbindir}/ftpd-topfield
+ install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ftpd-topfield
+}