summaryrefslogtreecommitdiff
path: root/packages/ftpd-topfield/ftpd-topfield_0.6.6.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-05-04 11:58:17 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-04 11:58:17 +0000
commit4e576d874c40f5358b6f3df70bb10bbcd2ae1717 (patch)
tree3f1479eef20a697bd6b8b5a0bbc45153809d7787 /packages/ftpd-topfield/ftpd-topfield_0.6.6.bb
parentf7dc666421ae0de3d8859aad345239cd13bcc256 (diff)
parent079dcb139403431fb19b752df884fc14aa506abe (diff)
merge of 46964b2367c68919c05de337c00dfb0f80a7bc6f
and 9ff24ed6ad4819ce51140dd2c4bd56863c7229be
Diffstat (limited to 'packages/ftpd-topfield/ftpd-topfield_0.6.6.bb')
-rwxr-xr-xpackages/ftpd-topfield/ftpd-topfield_0.6.6.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/ftpd-topfield/ftpd-topfield_0.6.6.bb b/packages/ftpd-topfield/ftpd-topfield_0.6.6.bb
new file mode 100755
index 0000000000..f7fdfb5466
--- /dev/null
+++ b/packages/ftpd-topfield/ftpd-topfield_0.6.6.bb
@@ -0,0 +1,35 @@
+# This package builds the ftpd-topfield program
+PR = "r0"
+DESCRIPTION = "ftpd-topfield - FTP access to TopField PVR"
+HOMEPAGE = "http://sourceforge.net/projects/puppy"
+MAINTAINER = "NSLU2 Linux <www.nslu2-linux.org>"
+SECTION = "net"
+LICENSE = "MIT"
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_6_6 \
+ cvs://anonymous@cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_6_6 \
+ file://init"
+
+# The source will end up in the subdirectory 'ftpd-topfield' - no release name
+S = "${WORKDIR}/ftpd-topfield"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "ftpd-topfield"
+INITSCRIPT_PARAMS = "defaults"
+
+# Just the one package at present
+PACKAGES = "${PN}"
+
+inherit autotools
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/ftpd ${D}${sbindir}/ftpd-topfield
+ install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ftpd-topfield
+}