summaryrefslogtreecommitdiff
path: root/packages/freeze/unfreeze.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-07-26 01:56:54 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-26 01:56:54 +0000
commit0636e261a937973904916973a80cdc139c1a0769 (patch)
treef8b70a36a759e030393d1b7a63827e61707a1c81 /packages/freeze/unfreeze.bb
parentf00bfb5d43172cceb5855fdf37ca9d01cd53ffe6 (diff)
Support for freezing BBFILES and reading BBFILES from a conf file.
Diffstat (limited to 'packages/freeze/unfreeze.bb')
-rw-r--r--packages/freeze/unfreeze.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/freeze/unfreeze.bb b/packages/freeze/unfreeze.bb
new file mode 100644
index 0000000000..0c0eadc66a
--- /dev/null
+++ b/packages/freeze/unfreeze.bb
@@ -0,0 +1,42 @@
+# unfreeze undoes the work of freeze by making the frozen
+# configuration fails empty (they just contain a comment).
+#
+DESCRIPTION = "Unfreeze the bitbake files in the build"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "console/networking"
+PRIORITY = "optional"
+LICENSE = "MIT"
+PR = "r0"
+
+INHIBIT_DEFAULT_DEPS = "1"
+PATCH_DEPENDS = ""
+ALLOW_EMPTY = 1
+PACKAGES = ""
+
+SRC_URI = "file://unfreeze"
+
+do_configure() {
+}
+do_compile() {
+}
+do_install() {
+}
+do_stage() {
+}
+
+do_build[nostamp] = 1
+do_build() {
+ # export FROZEN_DIR=<place to write conf files>
+ # export PKGDIR=<location of openembedded package source>
+ # unfreeze
+ set -x
+ # this is a sanity check:
+ if test -d "${PKGDIR}/packages"
+ then
+ FROZEN_DIR="${FROZEN_DIR}" DISTRO="${DISTRO}" sh "${WORKDIR}/unfreeze"
+ else
+ oenote "\$PKGDIR/packages ($PKGDIR/packages) not found"
+ oefatal "\$PKGDIR must be defined for freeze/unfreeze to work"
+ fi
+ set +x
+}