summaryrefslogtreecommitdiff
path: root/packages/freesmartphone
diff options
context:
space:
mode:
authorJan Lübbe <jluebbe@debian.org>2008-05-17 11:05:45 +0000
committerJan Lübbe <jluebbe@debian.org>2008-05-17 11:05:45 +0000
commitd7da261f228a694699f9ef66a1d5a200a335a141 (patch)
treedb1a2b6caf641a4ba3cab14b770d0cf92630f7d6 /packages/freesmartphone
parentfa719019d592dd4724f1bea024131e7524d9d44e (diff)
freesmartphone: add a fso-image and fix bb-files
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/python-ophoned/ophoned40
-rw-r--r--packages/freesmartphone/python-ophoned_git.bb4
-rw-r--r--packages/freesmartphone/python-ousaged/.mtn2git_empty0
-rw-r--r--packages/freesmartphone/python-ousaged/ousaged40
-rw-r--r--packages/freesmartphone/python-ousaged_git.bb36
-rw-r--r--packages/freesmartphone/zhone/.mtn2git_empty0
-rw-r--r--packages/freesmartphone/zhone/80zhone4
-rw-r--r--packages/freesmartphone/zhone_git.bb20
8 files changed, 140 insertions, 4 deletions
diff --git a/packages/freesmartphone/python-ophoned/ophoned b/packages/freesmartphone/python-ophoned/ophoned
new file mode 100644
index 0000000000..edc800711a
--- /dev/null
+++ b/packages/freesmartphone/python-ophoned/ophoned
@@ -0,0 +1,40 @@
+#! /bin/sh
+#
+# ophoned This shell script starts and stops the open phone daemon.
+#
+# chkconfig: 345 90 20
+# description: py-ophoned is the open phone daemon
+# processname: python
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin
+NAME=ophoned
+
+[ -f /etc/default/rcS ] && . /etc/default/rcS
+
+case "$1" in
+ start)
+ echo -n "Starting open phone daemon: "
+ start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/ophoned
+ if [ $? = 0 ]; then
+ echo "(ok)"
+ else
+ echo "(failed)"
+ fi
+ ;;
+ stop)
+ echo -n "Stopping open phone daemon: "
+ start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
+ rm -f /var/run/${NAME}.pid
+ echo "(done)"
+ ;;
+ restart|force-reload)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: /etc/init.d/ophoned {start|stop|restart|force-reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/freesmartphone/python-ophoned_git.bb b/packages/freesmartphone/python-ophoned_git.bb
index e494719bec..0a1c802041 100644
--- a/packages/freesmartphone/python-ophoned_git.bb
+++ b/packages/freesmartphone/python-ophoned_git.bb
@@ -19,9 +19,9 @@ S = "${WORKDIR}/git"
do_install_append() {
install -d ${D}${sysconfdir}/init.d/
install -m 0755 ${WORKDIR}/ophoned ${D}${sysconfdir}/init.d/
-# install -m 0644 ${WORKDIR}/odeviced.conf ${D}${sysconfdir}
+# install -m 0644 ${WORKDIR}/ophoned.conf ${D}${sysconfdir}
install -d ${D}${sysconfdir}/dbus-1/system.d/
-# mv -f ${D}${datadir}/etc/dbus-1/system.d/odeviced.conf ${D}${sysconfdir}/dbus-1/system.d/
+ mv -f ${D}${datadir}/etc/dbus-1/system.d/ophoned.conf ${D}${sysconfdir}/dbus-1/system.d/
}
RDEPENDS_${PN} += "\
diff --git a/packages/freesmartphone/python-ousaged/.mtn2git_empty b/packages/freesmartphone/python-ousaged/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/freesmartphone/python-ousaged/.mtn2git_empty
diff --git a/packages/freesmartphone/python-ousaged/ousaged b/packages/freesmartphone/python-ousaged/ousaged
new file mode 100644
index 0000000000..7b62d7f93c
--- /dev/null
+++ b/packages/freesmartphone/python-ousaged/ousaged
@@ -0,0 +1,40 @@
+#! /bin/sh
+#
+# odeviced This shell script starts and stops the open device daemon.
+#
+# chkconfig: 345 90 20
+# description: py-ousaged is the open usage daemon
+# processname: python
+
+PATH=/bin:/usr/bin:/sbin:/usr/sbin
+NAME=odeviced
+
+[ -f /etc/default/rcS ] && . /etc/default/rcS
+
+case "$1" in
+ start)
+ echo -n "Starting open usage daemon: "
+ start-stop-daemon --start --pidfile /var/run/${NAME}.pid --make-pidfile --background -x /usr/bin/ousaged
+ if [ $? = 0 ]; then
+ echo "(ok)"
+ else
+ echo "(failed)"
+ fi
+ ;;
+ stop)
+ echo -n "Stopping open usage daemon: "
+ start-stop-daemon --stop --pidfile /var/run/${NAME}.pid --oknodo
+ rm -f /var/run/${NAME}.pid
+ echo "(done)"
+ ;;
+ restart|force-reload)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: /etc/init.d/ousaged {start|stop|restart|force-reload}"
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/packages/freesmartphone/python-ousaged_git.bb b/packages/freesmartphone/python-ousaged_git.bb
new file mode 100644
index 0000000000..f9ba2856eb
--- /dev/null
+++ b/packages/freesmartphone/python-ousaged_git.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "The Open Usage Daemon Prototype in Python"
+HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenUsageDaemon"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+SECTION = "console/network"
+DEPENDS = "python-cython-native python-pyrex-native"
+LICENSE = "GPLv2"
+PV = "0.7.9+gitr${SRCREV}"
+PR = "r0"
+
+inherit distutils update-rc.d
+
+INITSCRIPT_NAME = "ousaged"
+INITSCRIPT_PARAMS = "defaults 20"
+
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/usaged.git;protocol=git;branch=master \
+ file://ousaged \
+"
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/ousaged ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ mv -f ${D}${datadir}/etc/dbus-1/system.d/ousaged.conf ${D}${sysconfdir}/dbus-1/system.d/
+}
+
+RDEPENDS_${PN} += "\
+ python-dbus \
+ python-pygobject \
+ python-pyrtc \
+ python-syslog \
+ python-odeviced \
+"
+
+FILES_${PN} += "${sysconfdir}"
diff --git a/packages/freesmartphone/zhone/.mtn2git_empty b/packages/freesmartphone/zhone/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/freesmartphone/zhone/.mtn2git_empty
diff --git a/packages/freesmartphone/zhone/80zhone b/packages/freesmartphone/zhone/80zhone
new file mode 100644
index 0000000000..4a698007b8
--- /dev/null
+++ b/packages/freesmartphone/zhone/80zhone
@@ -0,0 +1,4 @@
+#!/bin/sh -e
+zhone --fullscreen > /dev/null 2>&1 &
+renice -3 $!
+exit 0
diff --git a/packages/freesmartphone/zhone_git.bb b/packages/freesmartphone/zhone_git.bb
index 7fe6742069..419ee7a3e3 100644
--- a/packages/freesmartphone/zhone_git.bb
+++ b/packages/freesmartphone/zhone_git.bb
@@ -4,10 +4,26 @@ SECTION = "x11"
DEPENDS = "edje-native"
RDEPENDS = "task-python-efl python-textutils"
PV = "0.0.0+gitr${SRCREV}"
+PR = "r3"
-SRC_URI = "${FREESMARTPHONE_GIT}/zhone.git;protocol=git;branch=master"
+SRC_URI = "${FREESMARTPHONE_GIT}/zhone.git;protocol=git;branch=master \
+ file://80zhone"
S = "${WORKDIR}/git"
inherit autotools
-FILES_${PN} += "${datadir}"
+RDEPENDS_${PN} += "\
+ python-dbus \
+"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/X11/Xsession.d/
+ install -m 0755 ${WORKDIR}/80zhone ${D}${sysconfdir}/X11/Xsession.d/
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
+
+RCONFLICTS = "openmoko-session2"
+RREPLACES = "openmoko-session2"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+