summaryrefslogtreecommitdiff
path: root/packages/freesmartphone
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2008-08-14 23:48:23 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2008-08-14 23:48:23 +0000
commite9570b88fa18c49a68b5f44bffd7e2abb101f499 (patch)
tree083d8795a6ff13b6950f8da4ba4c507791b39fa2 /packages/freesmartphone
parent8e9a327b9c3924807b7c2093d6cc910213720440 (diff)
parent2792ce30ea1b3eb6a32bad578a956557e3040e89 (diff)
merge of '77de2c054faaf8169bea5553ae2311a39a581403'
and 'fd59ca4a2d1cdb56a15d6a3323721ce78836fe52'
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/illume-theme-freesmartphone_git.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/packages/freesmartphone/illume-theme-freesmartphone_git.bb b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
index 2d881214a0..3beffce09e 100644
--- a/packages/freesmartphone/illume-theme-freesmartphone_git.bb
+++ b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
@@ -2,11 +2,16 @@ DESCRIPTION = "Illume theme for the freesmartphone.org project"
HOMEPAGE = "http://illume.projects.openmoko.org/"
LICENSE = "MIT/BSD"
PV = "0.0+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "${FREESMARTPHONE_GIT}/artwork.git;protocol=git;branch=master"
S = "${WORKDIR}/git/illume"
+do_compile() {
+ cd illume && ./build.sh && cd ..
+ cd illume_init && ./build.sh && cd ..
+}
+
do_install() {
install -d ${D}${sysconfdir}/enlightenment
install -d ${D}${datadir}/enlightenment/data/themes/
@@ -15,8 +20,8 @@ do_install() {
# Make illume the default profile
echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
- install -m 0644 ${S}/illume.edj ${D}${datadir}/enlightenment/data/themes/
- install -m 0644 ${S}/illume_init.edj ${D}${datadir}/enlightenment/data/init/
+ install -m 0644 ${S}/illume/illume.edj ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/illume_init/illume_init.edj ${D}${datadir}/enlightenment/data/init/
}
RPROVIDES_${PN} = "illume-theme"