summaryrefslogtreecommitdiff
path: root/packages/freesmartphone
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-22 22:09:41 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-22 22:09:41 +0000
commitc48905930ee9f06a52744003a89e994ee06c19d4 (patch)
tree2daed49b982fb0852b213edee8005bb401c015ba /packages/freesmartphone
parent4279f33ce163887d0a035573f0e42414aa5cd05f (diff)
parentba24b9ff09c210680d0c4f1f883f2f771e12605c (diff)
merge of 'aadc54707d1990050b64f5354702d6454308b093'
and 'd2cf665b4d3013caa5979709d44b24fb0f2a9812'
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/illume-theme-freesmartphone_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/freesmartphone/illume-theme-freesmartphone_git.bb b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
new file mode 100644
index 0000000000..2d881214a0
--- /dev/null
+++ b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Illume theme for the freesmartphone.org project"
+HOMEPAGE = "http://illume.projects.openmoko.org/"
+LICENSE = "MIT/BSD"
+PV = "0.0+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/artwork.git;protocol=git;branch=master"
+S = "${WORKDIR}/git/illume"
+
+do_install() {
+ install -d ${D}${sysconfdir}/enlightenment
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -d ${D}${datadir}/enlightenment/data/init/
+
+ # Make illume the default profile
+ echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
+
+ install -m 0644 ${S}/illume.edj ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/illume_init.edj ${D}${datadir}/enlightenment/data/init/
+}
+
+RPROVIDES_${PN} = "illume-theme"
+CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"
+FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
+
+PACKAGE_ARCH_${PN} = "all"
+