summaryrefslogtreecommitdiff
path: root/packages/freesmartphone
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-15 23:38:21 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-15 23:38:21 +0100
commitcaf31970d2ed772cced98ac3a6caaf09596877cc (patch)
tree80378e02970cde121ec8a83fa889f11b46c48983 /packages/freesmartphone
parent4495f81376d61987ce7bb8590a1275fb56d39b0e (diff)
fso-abyss: version 0.3.0 supports a config file
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/fso-abyss/abyss.conf0
-rw-r--r--packages/freesmartphone/fso-abyss/om-gta01/abyss.conf16
-rw-r--r--packages/freesmartphone/fso-abyss/om-gta02/abyss.conf16
-rw-r--r--packages/freesmartphone/fso-abyss/om-gta03/abyss.conf16
-rw-r--r--packages/freesmartphone/fso-abyss_git.bb27
5 files changed, 71 insertions, 4 deletions
diff --git a/packages/freesmartphone/fso-abyss/abyss.conf b/packages/freesmartphone/fso-abyss/abyss.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/freesmartphone/fso-abyss/abyss.conf
diff --git a/packages/freesmartphone/fso-abyss/om-gta01/abyss.conf b/packages/freesmartphone/fso-abyss/om-gta01/abyss.conf
new file mode 100644
index 0000000000..2ff579d730
--- /dev/null
+++ b/packages/freesmartphone/fso-abyss/om-gta01/abyss.conf
@@ -0,0 +1,16 @@
+[omuxerd]
+# set to 1, when the first AllocChannel request opens a session
+autoopen = 1
+# set to 1, when the last ReleaseChannel closes the session
+autoclose = 1
+# set to 1, when closing the session should close the program
+autoexit = 1
+
+[session]
+# set 0 for 07.10 basic multiplexing, 1 for advanced
+mode = 1
+# set maximum 07.10 frame size
+framesize = 98
+# configure modem port
+port = /dev/ttySAC0
+speed = 115200
diff --git a/packages/freesmartphone/fso-abyss/om-gta02/abyss.conf b/packages/freesmartphone/fso-abyss/om-gta02/abyss.conf
new file mode 100644
index 0000000000..2ff579d730
--- /dev/null
+++ b/packages/freesmartphone/fso-abyss/om-gta02/abyss.conf
@@ -0,0 +1,16 @@
+[omuxerd]
+# set to 1, when the first AllocChannel request opens a session
+autoopen = 1
+# set to 1, when the last ReleaseChannel closes the session
+autoclose = 1
+# set to 1, when closing the session should close the program
+autoexit = 1
+
+[session]
+# set 0 for 07.10 basic multiplexing, 1 for advanced
+mode = 1
+# set maximum 07.10 frame size
+framesize = 98
+# configure modem port
+port = /dev/ttySAC0
+speed = 115200
diff --git a/packages/freesmartphone/fso-abyss/om-gta03/abyss.conf b/packages/freesmartphone/fso-abyss/om-gta03/abyss.conf
new file mode 100644
index 0000000000..1764c5b798
--- /dev/null
+++ b/packages/freesmartphone/fso-abyss/om-gta03/abyss.conf
@@ -0,0 +1,16 @@
+[omuxerd]
+# set to 1, when the first AllocChannel request opens a session
+autoopen = 1
+# set to 1, when the last ReleaseChannel closes the session
+autoclose = 1
+# set to 1, when closing the session should close the program
+autoexit = 1
+
+[session]
+# set 0 for 07.10 basic multiplexing, 1 for advanced
+mode = 0
+# set maximum 07.10 frame size
+framesize = 98
+# configure modem port
+port = /dev/ttySAC0
+speed = 115200
diff --git a/packages/freesmartphone/fso-abyss_git.bb b/packages/freesmartphone/fso-abyss_git.bb
index 45d2257c72..3cfff7dc9a 100644
--- a/packages/freesmartphone/fso-abyss_git.bb
+++ b/packages/freesmartphone/fso-abyss_git.bb
@@ -4,14 +4,33 @@ AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
SECTION = "console/network"
DEPENDS = "vala-native dbus dbus-glib libgsm0710"
LICENSE = "GPL"
-PV = "0.2.1+gitr${SRCREV}"
+PV = "0.3.0+gitr${SRCREV}"
PR = "r0"
-SRC_URI = "${FREESMARTPHONE_GIT}/fso-abyss.git;protocol=git;branch=master"
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/fso-abyss.git;protocol=git;branch=master \
+ file://abyss.conf \
+"
S = "${WORKDIR}/git"
inherit autotools
-#RCONFLICTS = "gsm0710muxd fso-gsm0710muxd"
+do_install_append() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/abyss.conf ${D}${sysconfdir}/
+}
-FILES_${PN} += "${datadir} ${sysconfdir}"
+PACKAGES =+ "${PN}-config"
+
+FILES_${PN} += "${sysconfdir} ${datadir}"
+RRECOMMENDS_${PN} = "${PN}-config"
+
+FILES_${PN}-config = "\
+ ${sysconfdir}/abyss.conf \
+"
+
+CONFFILES_${PN}-config = "\
+ ${sysconfdir}/abyss.conf \
+"
+
+PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"