summaryrefslogtreecommitdiff
path: root/packages/freesmartphone/pyneod_git.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-05-03 22:43:14 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-05-03 22:43:14 +0000
commit02c3dce797180ae9392503ff75f984f9d5599016 (patch)
tree4c1708a0053bff489b1d58c97f2b32a7813e2766 /packages/freesmartphone/pyneod_git.bb
parent2f0a1dfa7bc08742a457100062f2300fdc6c97b1 (diff)
convert freesmartphone recipes from SVN to GIT, add fso-autorev.inc
Diffstat (limited to 'packages/freesmartphone/pyneod_git.bb')
-rw-r--r--packages/freesmartphone/pyneod_git.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/packages/freesmartphone/pyneod_git.bb b/packages/freesmartphone/pyneod_git.bb
new file mode 100644
index 0000000000..7cdfaace22
--- /dev/null
+++ b/packages/freesmartphone/pyneod_git.bb
@@ -0,0 +1,67 @@
+DESCRIPTION = "Zad - daemons"
+HOMEPAGE = "http://neo1973-germany.de/wiki/Zad"
+AUTHOR = "M. Dietrich"
+SECTION = "console/network"
+DEPENDS = "python"
+LICENSE = "GPL"
+PV = "0.0.0+gitr${SRCREV}"
+PR = "r0"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "pyneod"
+INITSCRIPT_PARAMS = "defaults 40"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/pyneo.git;protocol=git;branch=master"
+S = "${WORKDIR}/git/pyneod"
+
+export D := "${D}"
+export PREFIX = "${prefix}"
+
+do_compile() {
+ :
+}
+
+do_install() {
+ python setup.py
+}
+
+RCONFLICTS = "gsmd"
+RREPLACES = "gsmd"
+RDEPENDS = "\
+ python-codecs \
+ python-compression \
+ python-crypt \
+ python-curses \
+ python-datetime \
+ python-dbus \
+ python-fcntl \
+ python-gdbm \
+ python-gst \
+ python-html \
+ python-io \
+ python-lang \
+ python-logging \
+ python-math \
+ python-mime \
+ python-netclient \
+ python-netserver \
+ python-pickle \
+ python-pprint \
+ python-pycrypto \
+ python-pygobject \
+ python-pyserial \
+ python-re \
+ python-readline \
+ python-shell \
+ python-simplejson \
+ python-sqlite3 \
+ python-stringold \
+ python-syslog \
+ python-threading \
+ python-xml \
+ python-zlib \
+"
+
+FILES_${PN} = "${datadir} ${sysconfdir} ${bindir}"
+PACKAGE_ARCH = "${MACHINE_ARCH}"