summaryrefslogtreecommitdiff
path: root/packages/freesmartphone/mickeydbus_git.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-07 19:05:40 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-07 19:05:40 +0000
commit9309b934b99abff81ceefc6015185cf41f75a833 (patch)
tree78f8c9eb259c8c280050684527bb7dc7c7218a5b /packages/freesmartphone/mickeydbus_git.bb
parentc4bb19566b06e30834f1615dda6fc1e4a9be1364 (diff)
add mdbus, a convenient dbus introspection/interaction console utility
Diffstat (limited to 'packages/freesmartphone/mickeydbus_git.bb')
-rw-r--r--packages/freesmartphone/mickeydbus_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/freesmartphone/mickeydbus_git.bb b/packages/freesmartphone/mickeydbus_git.bb
new file mode 100644
index 0000000000..cbd90e5030
--- /dev/null
+++ b/packages/freesmartphone/mickeydbus_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Mickey's DBus introspection and calling Program"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PV = "0.9.0+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 mickeydbus/mdbus ${D}${bindir}
+}
+
+RDEPENDS_${PN} = "\
+ python-dbus \
+"