summaryrefslogtreecommitdiff
path: root/packages/freesmartphone/illume-theme-freesmartphone_git.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2008-08-18 13:31:14 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2008-08-18 13:31:14 +0000
commitdb78439f15f3383086ac54ee38345af46a8e1a2f (patch)
treece044b6b1362ecdaad96348a16b2f2ae4b4cbe29 /packages/freesmartphone/illume-theme-freesmartphone_git.bb
parent4f4160a35379ed25427205c7b3c0b690d6992e29 (diff)
illume-theme-fso: Add config elements to make FSO a complete profile which can be switched
Diffstat (limited to 'packages/freesmartphone/illume-theme-freesmartphone_git.bb')
-rw-r--r--packages/freesmartphone/illume-theme-freesmartphone_git.bb20
1 files changed, 15 insertions, 5 deletions
diff --git a/packages/freesmartphone/illume-theme-freesmartphone_git.bb b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
index 3beffce09e..1ff193e87b 100644
--- a/packages/freesmartphone/illume-theme-freesmartphone_git.bb
+++ b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
@@ -1,8 +1,9 @@
DESCRIPTION = "Illume theme for the freesmartphone.org project"
HOMEPAGE = "http://illume.projects.openmoko.org/"
LICENSE = "MIT/BSD"
+DEPENDS = "edje-native eet-native"
PV = "0.0+gitr${SRCREV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "${FREESMARTPHONE_GIT}/artwork.git;protocol=git;branch=master"
S = "${WORKDIR}/git/illume"
@@ -10,18 +11,27 @@ S = "${WORKDIR}/git/illume"
do_compile() {
cd illume && ./build.sh && cd ..
cd illume_init && ./build.sh && cd ..
+ cd illume-config
+ eet -e e.cfg config e.src 1
+ eet -e module.battery.cfg config module.battery.src 1
+ eet -e module.illume.cfg config module.illume.src 1
}
do_install() {
install -d ${D}${sysconfdir}/enlightenment
install -d ${D}${datadir}/enlightenment/data/themes/
install -d ${D}${datadir}/enlightenment/data/init/
+ install -d ${D}${datadir}/enlightenment/data/config/fso/
- # Make illume the default profile
- echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
+ # Make fso the default profile
+ echo 'E_PROFILE="-profile fso"' > ${D}${sysconfdir}/enlightenment/default_profile
- install -m 0644 ${S}/illume/illume.edj ${D}${datadir}/enlightenment/data/themes/
- install -m 0644 ${S}/illume_init/illume_init.edj ${D}${datadir}/enlightenment/data/init/
+ install -m 0644 ${S}/illume/fso.edj ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/illume_init/fso_init.edj ${D}${datadir}/enlightenment/data/init/
+
+ install -m 0644 ${S}/illume-config/e.cfg ${D}${datadir}/enlightenment/data/config/fso/
+ install -m 0644 ${S}/illume-config/module.battery.cfg ${D}${datadir}/enlightenment/data/config/fso/
+ install -m 0644 ${S}/illume-config/module.illume.cfg ${D}${datadir}/enlightenment/data/config/fso/
}
RPROVIDES_${PN} = "illume-theme"