summaryrefslogtreecommitdiff
path: root/packages/freesmartphone/illume-theme-freesmartphone_git.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2008-08-08 14:22:12 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2008-08-08 14:22:12 +0000
commit5b7c5937a7994b57fd8401f02b78c47fb274bf42 (patch)
treed7899bff64d00b8520ed4f188db5fd590821e412 /packages/freesmartphone/illume-theme-freesmartphone_git.bb
parent91c871bcf8db9904cf4fea3b63d9f460c8f85278 (diff)
illume-theme-freesmartphone: Build theme from source.
Diffstat (limited to 'packages/freesmartphone/illume-theme-freesmartphone_git.bb')
-rw-r--r--packages/freesmartphone/illume-theme-freesmartphone_git.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/packages/freesmartphone/illume-theme-freesmartphone_git.bb b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
index 2d881214a0..3beffce09e 100644
--- a/packages/freesmartphone/illume-theme-freesmartphone_git.bb
+++ b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
@@ -2,11 +2,16 @@ DESCRIPTION = "Illume theme for the freesmartphone.org project"
HOMEPAGE = "http://illume.projects.openmoko.org/"
LICENSE = "MIT/BSD"
PV = "0.0+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "${FREESMARTPHONE_GIT}/artwork.git;protocol=git;branch=master"
S = "${WORKDIR}/git/illume"
+do_compile() {
+ cd illume && ./build.sh && cd ..
+ cd illume_init && ./build.sh && cd ..
+}
+
do_install() {
install -d ${D}${sysconfdir}/enlightenment
install -d ${D}${datadir}/enlightenment/data/themes/
@@ -15,8 +20,8 @@ do_install() {
# Make illume the default profile
echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
- install -m 0644 ${S}/illume.edj ${D}${datadir}/enlightenment/data/themes/
- install -m 0644 ${S}/illume_init.edj ${D}${datadir}/enlightenment/data/init/
+ install -m 0644 ${S}/illume/illume.edj ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/illume_init/illume_init.edj ${D}${datadir}/enlightenment/data/init/
}
RPROVIDES_${PN} = "illume-theme"