summaryrefslogtreecommitdiff
path: root/packages/freesmartphone/gsm0710muxd_svn.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-04-30 12:14:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2008-04-30 12:14:33 +0000
commit89288fe72787367690f35e0e636429bcc9d2d5ae (patch)
tree7d392b5715bf9fcaf4b35a132d97b28b2dbfb5cd /packages/freesmartphone/gsm0710muxd_svn.bb
parent63f966d92bfe882fd7b904c024ac3ade8bd6a91c (diff)
parent2eebccf63414618a6da891784eef7635a885e33e (diff)
merge of '519fb232d0f89064395bf96f19e36d9567a2f25c'
and 'a9af97a0d7d40825f32be70ec5fdc7757c965989'
Diffstat (limited to 'packages/freesmartphone/gsm0710muxd_svn.bb')
-rw-r--r--packages/freesmartphone/gsm0710muxd_svn.bb26
1 files changed, 8 insertions, 18 deletions
diff --git a/packages/freesmartphone/gsm0710muxd_svn.bb b/packages/freesmartphone/gsm0710muxd_svn.bb
index 09b3b8c4fb..07eac3c919 100644
--- a/packages/freesmartphone/gsm0710muxd_svn.bb
+++ b/packages/freesmartphone/gsm0710muxd_svn.bb
@@ -2,32 +2,22 @@ DESCRIPTION = "GSM 07.10 muxer userspace daemon"
HOMEPAGE = "http://www.freesmartphone.org"
AUTHOR = "M. Dietrich"
SECTION = "console/network"
-DEPENDS = "intltool-native dbus dbus-glib"
+DEPENDS = "dbus dbus-glib"
RDEPENDS = "dbus dbus-glib"
LICENSE = "GPL"
-PV = "0.9.0+svnr${SRCREV}"
-PR = "r0"
+PV = "0.9.1+svnr${SRCREV}"
+PR = "r1"
SRC_URI = "svn://projects.linuxtogo.org/svn/smartphones/trunk/software;module=gsm0710muxd"
S = "${WORKDIR}/gsm0710muxd"
inherit autotools
+# install init script for people who want to manually
+# start/stop it, but don't add runlevels.
do_install_append() {
- # temp hack
- mv -f ${D}${datadir}/dbus-1/system-services/org.freesmartphone.GSM.MUX.service ${D}${datadir}/dbus-1/system-services/org.mobile.mux.service
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 data/gsm0710muxd ${D}${sysconfdir}/init.d/
}
-pkg_postinst_${PN}() {
- # can't do this offline
- if [ "x$D" != "x" ]; then
- exit 1
- fi
- # reload dbus configuration files
- for i in `pidof dbus-daemon`; do
- kill -SIGHUP $i
- done
-}
-
-FILES_${PN} += "${datadir}"
-
+FILES_${PN} += "${datadir} ${sysconfdir}"