summaryrefslogtreecommitdiff
path: root/packages/freesmartphone/gsm0710muxd_git.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-05-03 22:43:14 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-05-03 22:43:14 +0000
commit02c3dce797180ae9392503ff75f984f9d5599016 (patch)
tree4c1708a0053bff489b1d58c97f2b32a7813e2766 /packages/freesmartphone/gsm0710muxd_git.bb
parent2f0a1dfa7bc08742a457100062f2300fdc6c97b1 (diff)
convert freesmartphone recipes from SVN to GIT, add fso-autorev.inc
Diffstat (limited to 'packages/freesmartphone/gsm0710muxd_git.bb')
-rw-r--r--packages/freesmartphone/gsm0710muxd_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/freesmartphone/gsm0710muxd_git.bb b/packages/freesmartphone/gsm0710muxd_git.bb
new file mode 100644
index 0000000000..d5e9bd0672
--- /dev/null
+++ b/packages/freesmartphone/gsm0710muxd_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "GSM 07.10 muxer userspace daemon"
+HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/gsm0710muxd"
+AUTHOR = "M. Dietrich"
+SECTION = "console/network"
+DEPENDS = "dbus dbus-glib"
+RDEPENDS = "dbus dbus-glib"
+LICENSE = "GPL"
+PV = "0.9.1+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/gsm0710muxd.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+# install init script for people who want to manually
+# start/stop it, but don't add runlevels.
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 data/gsm0710muxd ${D}${sysconfdir}/init.d/
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"