summaryrefslogtreecommitdiff
path: root/packages/freesmartphone/fso-gpsd_git.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-09-27 12:57:34 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-09-27 12:57:34 +0000
commitef8b4e081c718b1a68a4aaf65b9b40aab97a1bf6 (patch)
tree34998bf0ae60084b2031b3bbe032e342e3b5bf04 /packages/freesmartphone/fso-gpsd_git.bb
parent56ab9fc19519aca3a0e8b8280837f1f7866927ef (diff)
fso-gpsd git add init script and launch on system startup
Diffstat (limited to 'packages/freesmartphone/fso-gpsd_git.bb')
-rw-r--r--packages/freesmartphone/fso-gpsd_git.bb21
1 files changed, 17 insertions, 4 deletions
diff --git a/packages/freesmartphone/fso-gpsd_git.bb b/packages/freesmartphone/fso-gpsd_git.bb
index 85cb5194b5..4382038c64 100644
--- a/packages/freesmartphone/fso-gpsd_git.bb
+++ b/packages/freesmartphone/fso-gpsd_git.bb
@@ -1,15 +1,28 @@
-DESCRIPTION = "gspd compatibility layer for frameworkd"
+DESCRIPTION = "freesmartphone.org gpsd compatibility daemon"
LICENSE = "GPL"
SECTION = "network"
DEPENDS = "dbus-glib"
PV = "0.6+${PR}+gitr${SRCREV}"
-PR = "r0"
+PR = "r1"
-SRC_URI = "${FREESMARTPHONE_GIT}/fso-gpsd.git;protocol=git;branch=master"
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/fso-gpsd.git;protocol=git;branch=master \
+ file://fso-gpsd \
+"
S = "${WORKDIR}/git"
-inherit autotools
+inherit autotools update-rc.d
+INITSCRIPT_NAME = "gpsd"
+INITSCRIPT_PARAMS = "defaults 35"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/fso-gpsd ${D}${sysconfdir}/init.d/
+}
+
+FILES_${PN} += "${sysconfdir}"
+RDEPENDS_${PN} = "frameworkd"
RPROVIDES_${PN} = "gpsd"
RCONFLICTS_${PN} = "gpsd"
RREPLACES_${PN} = "gpsd"