summaryrefslogtreecommitdiff
path: root/packages/fluxbox
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-01-02 00:04:48 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-01-02 00:04:48 +0000
commit49377b6bf81825481bb3c949520b7819af605bad (patch)
tree1a343f738e97f2b9f8929b7f48c81fe567fb69d4 /packages/fluxbox
parent49168b1bd065468e41c98b5c294be98dc90f533e (diff)
parent8d7a61dba67097e2b57ee4be1a531a7e3fd2153e (diff)
merge of '132be09ee353f798eadc984f8f09e27e68180850'
and 'c0e1d74b2a331789caaf72b458b57924d21c7da3'
Diffstat (limited to 'packages/fluxbox')
-rw-r--r--packages/fluxbox/fluxbox_0.99+1.0rc.bb10
-rw-r--r--packages/fluxbox/fluxbox_svn.bb10
2 files changed, 10 insertions, 10 deletions
diff --git a/packages/fluxbox/fluxbox_0.99+1.0rc.bb b/packages/fluxbox/fluxbox_0.99+1.0rc.bb
index 81d2952e23..3f271a57a4 100644
--- a/packages/fluxbox/fluxbox_0.99+1.0rc.bb
+++ b/packages/fluxbox/fluxbox_0.99+1.0rc.bb
@@ -70,25 +70,25 @@ do_install_append() {
install -d ${D}/usr/share/fluxbox
install -d ${D}/usr/share/fluxbox/styles
install -d ${D}/etc
-
+
install -m 0644 ${WORKDIR}/apps.gpe.* ${D}/usr/share/fluxbox
install -m 0644 ${WORKDIR}/keys.* ${D}/usr/share/fluxbox
install -m 0755 ${WORKDIR}/fluxbox-gpe.session ${D}/usr/share/fluxbox/session
install -m 0644 ${WORKDIR}/style.gpe-default ${D}/usr/share/fluxbox/styles/gpe-default
install -m 0755 ${WORKDIR}/fluxbox-gpe-session ${D}/usr/bin
- install -m 0755 ${WORKDIR}/gpe-logout.fluxbox ${D}/usr/bin
- install -m 0644 ${WORKDIR}/keylaunchrc.fluxbox ${D}/etc
+ install -m 0755 ${WORKDIR}/gpe-logout.fluxbox ${D}/usr/bin
+ install -m 0644 ${WORKDIR}/keylaunchrc.fluxbox ${D}/etc
}
######################################################################################
-pkg_postinst_${PN}-gpe() {
+pkg_postinst_${PN}-gpe() {
update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/fluxbox-gpe-session 15
update-alternatives --install /usr/bin/gpe-logout gpe-logout /usr/bin/gpe-logout.fluxbox 15
update-alternatives --install /etc/keylaunchrc keylaunchrc /etc/keylaunchrc.fluxbox 15
}
-pkg_postrm_${PN}-gpe() {
+pkg_postrm_${PN}-gpe() {
update-alternatives --remove x-window-manager /usr/bin/fluxbox-gpe-session
update-alternatives --remove gpe-logout /usr/bin/gpe-logout.fluxbox
update-alternatives --remove keylaunchrc /etc/keylaunchrc.fluxbox
diff --git a/packages/fluxbox/fluxbox_svn.bb b/packages/fluxbox/fluxbox_svn.bb
index 56e799a272..ffaa7da5b4 100644
--- a/packages/fluxbox/fluxbox_svn.bb
+++ b/packages/fluxbox/fluxbox_svn.bb
@@ -71,25 +71,25 @@ do_install_append() {
install -d ${D}/usr/share/fluxbox
install -d ${D}/usr/share/fluxbox/styles
install -d ${D}/etc
-
+
install -m 0644 ${WORKDIR}/apps.gpe.* ${D}/usr/share/fluxbox
install -m 0644 ${WORKDIR}/keys.* ${D}/usr/share/fluxbox
install -m 0755 ${WORKDIR}/fluxbox-gpe.session ${D}/usr/share/fluxbox/session
install -m 0644 ${WORKDIR}/style.gpe-default ${D}/usr/share/fluxbox/styles/gpe-default
install -m 0755 ${WORKDIR}/fluxbox-gpe-session ${D}/usr/bin
- install -m 0755 ${WORKDIR}/gpe-logout.fluxbox ${D}/usr/bin
- install -m 0644 ${WORKDIR}/keylaunchrc.fluxbox ${D}/etc
+ install -m 0755 ${WORKDIR}/gpe-logout.fluxbox ${D}/usr/bin
+ install -m 0644 ${WORKDIR}/keylaunchrc.fluxbox ${D}/etc
}
######################################################################################
-pkg_postinst_${PN}-gpe() {
+pkg_postinst_${PN}-gpe() {
update-alternatives --install /usr/bin/x-window-manager x-window-manager /usr/bin/fluxbox-gpe-session 15
update-alternatives --install /usr/bin/gpe-logout gpe-logout /usr/bin/gpe-logout.fluxbox 15
update-alternatives --install /etc/keylaunchrc keylaunchrc /etc/keylaunchrc.fluxbox 15
}
-pkg_postrm_${PN}-gpe() {
+pkg_postrm_${PN}-gpe() {
update-alternatives --remove x-window-manager /usr/bin/fluxbox-gpe-session
update-alternatives --remove gpe-logout /usr/bin/gpe-logout.fluxbox
update-alternatives --remove keylaunchrc /etc/keylaunchrc.fluxbox