summaryrefslogtreecommitdiff
path: root/packages/flashrom/files
diff options
context:
space:
mode:
authorKalev Lember <kalev@smartlink.ee>2008-10-25 12:57:31 +0300
committerKalev Lember <kalev@smartlink.ee>2008-10-25 13:22:15 +0300
commitef4996ca83e6945a7b8b69ad91f6172533299303 (patch)
treed75ac6c290c2d2fb627fc7a5c4c17bc094323f6a /packages/flashrom/files
parent0e578dfc600390132af6a4909f1e9f59952720e9 (diff)
flashrom svn: new recipe
* add makefile patch to not strip executable during install, we do that while packaging
Diffstat (limited to 'packages/flashrom/files')
-rw-r--r--packages/flashrom/files/makefile-disable-strip.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/flashrom/files/makefile-disable-strip.patch b/packages/flashrom/files/makefile-disable-strip.patch
new file mode 100644
index 0000000000..0296e1d99e
--- /dev/null
+++ b/packages/flashrom/files/makefile-disable-strip.patch
@@ -0,0 +1,18 @@
+--- flashrom/Makefile.orig 2008-10-25 12:13:21.000000000 +0300
++++ flashrom/Makefile 2008-10-25 12:14:04.000000000 +0300
+@@ -17,7 +17,6 @@
+ LDFLAGS = -lpci -lz
+ else
+ LDFLAGS = -lpci -lz
+-STRIP_ARGS = -s
+ endif
+ ifeq ($(OS_ARCH), FreeBSD)
+ CFLAGS += -I/usr/local/include
+@@ -40,7 +39,6 @@
+
+ $(PROGRAM): $(OBJS)
+ $(CC) -o $(PROGRAM) $(OBJS) $(LDFLAGS)
+- $(STRIP) $(STRIP_ARGS) $(PROGRAM)
+
+ flashrom.o: flashrom.c
+ $(CC) -c $(CFLAGS) $(SVNDEF) $(CPPFLAGS) $< -o $@