summaryrefslogtreecommitdiff
path: root/packages/file/file_4.18.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-11-09 10:37:33 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-11-09 10:37:33 +0000
commit13b1746414d7674c0dfc3e53c4a9c92d8c6c8288 (patch)
tree6e957a2ec95b81b5c8a743c1a6e635a479ad4250 /packages/file/file_4.18.bb
parentb83d36707c2292235878fcec4aa270f3ce14426f (diff)
file, file-native 4.18 : replaced the magic files for filesystems and dump
for the ones for 4.16. The stuff that doesnt compile in 4.18 is new so it looks like a lack of QA on part of this release that they dont work.
Diffstat (limited to 'packages/file/file_4.18.bb')
-rw-r--r--packages/file/file_4.18.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/file/file_4.18.bb b/packages/file/file_4.18.bb
new file mode 100644
index 0000000000..697d4ffb9f
--- /dev/null
+++ b/packages/file/file_4.18.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "File attempts to classify files depending \
+on their contents and prints a description if a match is found."
+SECTION = "console/utils"
+LICENSE = "BSD-ADV"
+DEPENDS = "file-native"
+
+SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
+ file://dump \
+ file://filesystems"
+S = "${WORKDIR}/file-${PV}"
+
+inherit autotools
+
+do_configure_prepend() {
+ sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
+ cp ${WORKDIR}/dump ${S}/magic/Magdir/
+ cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
+}
+
+do_stage() {
+ autotools_stage_all
+}