summaryrefslogtreecommitdiff
path: root/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
diff options
context:
space:
mode:
authorJunqian Gordon Xu <xjqian@gmail.com>2008-02-24 11:14:19 +0000
committerJunqian Gordon Xu <xjqian@gmail.com>2008-02-24 11:14:19 +0000
commitd9a1af61ed037f1d5847bbaca10000b248937ce1 (patch)
tree79584c91874bc602b7c48451e42efb947d636bc6 /packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
parentf7d9bfb1a8285e46b6156a8cc7cced5d00a308d1 (diff)
ffmpeg: make svn buildable, fix configure options for 0.4.9-pre1, unify, clean up
* fix svn using SRCDATE * reformat EXTRA_OECONF to make the order of the options follow ./configure --help * NOTE: --cpu(0.4.9-pre1) equals --arch(svn); while --tune(0.4.9-pre1) equals --cpu(svn) * NOTE: oe uses --march and --mtune, so the above optimization by ffmpeg (--mcpu) is not really needed * NOTE: but we try to make --cpu(0.4.9-pre1) or --arch(svn) as close to $TARGET_ARCH as possible * checked --march and --mtune and $TARGET_CFLAGS are used correctly * remove unnecessary FLAGS, configure options, oe_runconf(), etc in either svn or pre1 * unify svn and 0.4.9-pre1, however not much can be done for packaging and staging * QA: add LEAD_SONAME, fix DESCRIPTION, HOME, AUTHOR
Diffstat (limited to 'packages/ffmpeg/ffmpeg_0.4.9-pre1.bb')
-rw-r--r--packages/ffmpeg/ffmpeg_0.4.9-pre1.bb64
1 files changed, 32 insertions, 32 deletions
diff --git a/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb b/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
index defc37daa0..6df6d89ca0 100644
--- a/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
+++ b/packages/ffmpeg/ffmpeg_0.4.9-pre1.bb
@@ -1,16 +1,18 @@
require ffmpeg.inc
-DEPENDS += "faad2"
-
-PR = "r2"
+PR = "r3"
SRC_URI = "${SOURCEFORGE_MIRROR}/ffmpeg/ffmpeg-${PV}.tar.gz \
- file://configure.patch;patch=0 \
- file://gcc4.patch;patch=1 \
- file://soname.patch;patch=1 \
- "
+ file://configure.patch;patch=0 \
+ file://gcc4.patch;patch=1 \
+ file://soname.patch;patch=1 \
+ "
EXTRA_OECONF += " \
+ \
+ --prefix=${D}${prefix} \
+ --mandir=${D}${prefix}/share/man \
+ \
--enable-mp3lame \
--enable-vorbis \
--enable-faad \
@@ -22,39 +24,37 @@ EXTRA_OECONF += " \
--disable-amr_nb \
--enable-amr_nb-fixed \
--disable-amr_wb \
- --enable-zlib \
\
+ --cpu=${TARGET_ARCH} \
+ --tune=${PACKAGE_ARCH} \
+ --extra-ldflags="-la52" \
\
- --extra-cflags=\$(TARGET_CFLAGS) \
- --extra-ldflags=\$(TARGET_LDFLAGS) \
- --extra-libs=\$(TARGET_LDFLAGS) \
- \
- --prefix=${D}${prefix} \
- --mandir=${D}${prefix}/share/man \
+ --disable-audio-beos \
+ --disable-v4l \
+ --disable-dv1394 \
"
-PACKAGES += "libavcodec libavcodec-dev libavformat libavformat-dev"
-
-FILES_${PN} += "${libdir}/vhook"
-FILES_${PN}-dev = "${includedir}"
-FILES_${PN}-dbg += "${libdir}/vhook/.debug"
-
-FILES_libavcodec = "${libdir}/libavcodec*.so.*"
-FILES_libavcodec-dev = "${libdir}/libavcodec*.so ${libdir}/libavcodec*.la ${libdir}/libavcodec*.a"
-FILES_libavformat = "${libdir}/libavformat*.so.*"
-FILES_libavformat-dev = "${libdir}/libavformat*.so ${libdir}/libavformat*.la ${libdir}/libavformat*.a"
-
do_stage() {
- oe_libinstall -a -so -C libavcodec libavcodec ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C libavcodec libavcodec ${STAGING_LIBDIR}
oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}
install -d ${STAGING_INCDIR}/ffmpeg
- install -m 0644 ${S}/libavcodec/avcodec.h ${STAGING_INCDIR}/ffmpeg/avcodec.h
- install -m 0644 ${S}/libavcodec/common.h ${STAGING_INCDIR}/ffmpeg/common.h
+
+ install -m 0644 ${S}/libavcodec/avcodec.h ${STAGING_INCDIR}/ffmpeg/avcodec.h
+ install -m 0644 ${S}/libavcodec/common.h ${STAGING_INCDIR}/ffmpeg/common.h
install -m 0644 ${S}/libavcodec/rational.h ${STAGING_INCDIR}/ffmpeg/rational.h
- install -m 0644 ${S}/libavformat/avformat.h ${STAGING_INCDIR}/ffmpeg/avformat.h
- install -m 0644 ${S}/libavformat/avio.h ${STAGING_INCDIR}/ffmpeg/avio.h
- install -m 0644 ${S}/libavformat/rtp.h ${STAGING_INCDIR}/ffmpeg/rtp.h
- install -m 0644 ${S}/libavformat/rtsp.h ${STAGING_INCDIR}/ffmpeg/rtsp.h
+
+ install -m 0644 ${S}/libavformat/avformat.h ${STAGING_INCDIR}/ffmpeg/avformat.h
+ install -m 0644 ${S}/libavformat/avio.h ${STAGING_INCDIR}/ffmpeg/avio.h
+ install -m 0644 ${S}/libavformat/rtp.h ${STAGING_INCDIR}/ffmpeg/rtp.h
+ install -m 0644 ${S}/libavformat/rtsp.h ${STAGING_INCDIR}/ffmpeg/rtsp.h
install -m 0644 ${S}/libavformat/rtspcodes.h ${STAGING_INCDIR}/ffmpeg/rtspcodes.h
}
+
+PACKAGES += "libavcodec libavcodec-dev \
+ libavformat libavformat-dev"
+
+FILES_libavcodec = "${libdir}/libavcodec*.so.*"
+FILES_libavcodec-dev = "${libdir}/libavcodec*.so"
+FILES_libavformat = "${libdir}/libavformat*.so.*"
+FILES_libavformat-dev = "${libdir}/libavformat*.so"