summaryrefslogtreecommitdiff
path: root/packages/fakeroot/fakeroot_1.9.1.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-01-24 12:23:56 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-01-24 12:23:56 +0000
commit2bc8cfae84d8b9663ec7401c408407c6400816e1 (patch)
tree78549cb37e5a34caf9b296f7c0c36b9e2e6ca70a /packages/fakeroot/fakeroot_1.9.1.bb
parent99be5b3387c167d9c4873032e31429848071c974 (diff)
fakeroot: update to latest version 1.9.1
* 1.8.3 had become unfetchable * use DEBIAN_MIRROR * some clean-up (StyleGuide, move common files to files/ instead of $PN-$PV/
Diffstat (limited to 'packages/fakeroot/fakeroot_1.9.1.bb')
-rw-r--r--packages/fakeroot/fakeroot_1.9.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/fakeroot/fakeroot_1.9.1.bb b/packages/fakeroot/fakeroot_1.9.1.bb
new file mode 100644
index 0000000000..aaf696d79d
--- /dev/null
+++ b/packages/fakeroot/fakeroot_1.9.1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org/"
+SECTION = "base"
+LICENSE = "GPL"
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+PR = "r1"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+ file://configure-libtool.patch;patch=1"
+
+inherit autotools
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/fakeroot
+ install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+ autotools_stage_all
+}