summaryrefslogtreecommitdiff
path: root/packages/fakeroot/fakeroot-native_1.9.4.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-04-01 11:59:31 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-04-01 11:59:31 +0000
commit8e225a08060e95dad44b0a4cfab79bd5138f68ea (patch)
treea3876091786590e78c01b5e24a2f12d5cad21caf /packages/fakeroot/fakeroot-native_1.9.4.bb
parenta28cb0061620956bce87d42d4a172c8140c96c61 (diff)
fakeroot: update to 1.9.4. fixes do_fetch problem reported as 4143.
Diffstat (limited to 'packages/fakeroot/fakeroot-native_1.9.4.bb')
-rw-r--r--packages/fakeroot/fakeroot-native_1.9.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/fakeroot/fakeroot-native_1.9.4.bb b/packages/fakeroot/fakeroot-native_1.9.4.bb
new file mode 100644
index 0000000000..77d6f58651
--- /dev/null
+++ b/packages/fakeroot/fakeroot-native_1.9.4.bb
@@ -0,0 +1,21 @@
+require fakeroot_${PV}.bb
+
+RDEPENDS="util-linux-native"
+
+SRC_URI += "file://fix-prefix.patch;patch=1 "
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+