summaryrefslogtreecommitdiff
path: root/packages/fakeroot/fakeroot-native_1.7.1.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-10 08:33:56 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-10 08:33:56 +0000
commitc2936ad115a3e471324875ebc28882db58d47a4d (patch)
treede83963ea4017e5bda48637074b8d329c027af03 /packages/fakeroot/fakeroot-native_1.7.1.bb
parent5af596c69226a8f1667ce77d5bd7a98ec083e018 (diff)
parent7917d58ed32f5e886a08c43df325b5daac7bfab5 (diff)
merge of 'ca79cbe803b8aa5bd6d3ebe944504e5af8234d59'
and 'fc9df3f6bc3d16669463fde20e46e8b5a683ad84'
Diffstat (limited to 'packages/fakeroot/fakeroot-native_1.7.1.bb')
-rw-r--r--packages/fakeroot/fakeroot-native_1.7.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/fakeroot/fakeroot-native_1.7.1.bb b/packages/fakeroot/fakeroot-native_1.7.1.bb
new file mode 100644
index 0000000000..6f2969e181
--- /dev/null
+++ b/packages/fakeroot/fakeroot-native_1.7.1.bb
@@ -0,0 +1,21 @@
+SECTION = "base"
+require fakeroot_${PV}.bb
+inherit native
+RDEPENDS="util-linux-native"
+
+SRC_URI += "file://fix-prefix.patch;patch=1 \
+ file://work-with-older-libtool.patch;patch=1"
+S = "${WORKDIR}/fakeroot-${PV}"
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+