summaryrefslogtreecommitdiff
path: root/packages/ezx/opentapi_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-01-02 19:31:02 +0000
committerKoen Kooi <koen@openembedded.org>2007-01-02 19:31:02 +0000
commit4cfc3d5ccd4cd3dc572958bdad127856be41cb2c (patch)
treeec1017dd159196314b0c49e2e4586a5eb4b148f9 /packages/ezx/opentapi_svn.bb
parent9f9094de71fc15decea442de3aebfdfec3b600ad (diff)
parent68efee7f26b15d2c3bab3fb7f807c5853ca6da77 (diff)
merge of '1944e442d97092991784475bf4b8980e60c5c3fc'
and 'c6043a6be9941ce6182b30748b51b8f191e04bc8'
Diffstat (limited to 'packages/ezx/opentapi_svn.bb')
-rw-r--r--packages/ezx/opentapi_svn.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/packages/ezx/opentapi_svn.bb b/packages/ezx/opentapi_svn.bb
index e27aa68b97..a617f5b45b 100644
--- a/packages/ezx/opentapi_svn.bb
+++ b/packages/ezx/opentapi_svn.bb
@@ -3,12 +3,23 @@ LICENSE = "GPLv2"
PV = "0.0+svn${SRCDATE}"
-SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=opentapi;proto=http"
+SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=opentapi;proto=http \
+ file://opentapi.init \
+ "
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "opentapi"
+INITSCRIPT_PARAMS = "defaults"
+
S = "${WORKDIR}/${PN}"
do_install() {
install -d ${D}${bindir}
install -m 755 opentapi ${D}${bindir}
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/opentapi.init ${D}${sysconfdir}/init.d/opentapi
}