summaryrefslogtreecommitdiff
path: root/packages/ezx/opentapi_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-01-02 14:15:19 +0000
committerKoen Kooi <koen@openembedded.org>2007-01-02 14:15:19 +0000
commitdaf0b3dea872627719c41f3b060b1a76b8b23f93 (patch)
tree9c82370d743ae7c81a4050508a78ccbc38e4a555 /packages/ezx/opentapi_svn.bb
parente4d3aacc1b849cd56433b8785e8267fbab7fb4d6 (diff)
opentapi: add (untested) initscript
Diffstat (limited to 'packages/ezx/opentapi_svn.bb')
-rw-r--r--packages/ezx/opentapi_svn.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/packages/ezx/opentapi_svn.bb b/packages/ezx/opentapi_svn.bb
index e27aa68b97..a617f5b45b 100644
--- a/packages/ezx/opentapi_svn.bb
+++ b/packages/ezx/opentapi_svn.bb
@@ -3,12 +3,23 @@ LICENSE = "GPLv2"
PV = "0.0+svn${SRCDATE}"
-SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=opentapi;proto=http"
+SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=opentapi;proto=http \
+ file://opentapi.init \
+ "
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "opentapi"
+INITSCRIPT_PARAMS = "defaults"
+
S = "${WORKDIR}/${PN}"
do_install() {
install -d ${D}${bindir}
install -m 755 opentapi ${D}${bindir}
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/opentapi.init ${D}${sysconfdir}/init.d/opentapi
}