summaryrefslogtreecommitdiff
path: root/packages/ezx/ezx-boot-usb-native_svn.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-12-06 17:42:26 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-12-06 17:42:26 +0100
commit1aedd0303d93a92d0fc01545f5e5513c3bf7762b (patch)
tree3f798f09936a763125d9b303a533f5f8cda1e195 /packages/ezx/ezx-boot-usb-native_svn.bb
parent5b9e5c6108e8517473a5ae13acaa75ff32bd0619 (diff)
ezx-boot-usb-native: catch up with new developments & remove outdated versions
Diffstat (limited to 'packages/ezx/ezx-boot-usb-native_svn.bb')
-rw-r--r--packages/ezx/ezx-boot-usb-native_svn.bb29
1 files changed, 26 insertions, 3 deletions
diff --git a/packages/ezx/ezx-boot-usb-native_svn.bb b/packages/ezx/ezx-boot-usb-native_svn.bb
index 6ab4263dba..a0a8affdc0 100644
--- a/packages/ezx/ezx-boot-usb-native_svn.bb
+++ b/packages/ezx/ezx-boot-usb-native_svn.bb
@@ -1,5 +1,28 @@
-require ezx-boot-usb-native.inc
+DESCRIPTION = "Boots a Motorola EZX device with a user supplied kernel zImage"
+DEPENDS = "libusb-native virtual/kernel"
+SECTION = "devel"
+AUTHOR = "Team OpenEZX <openezx-devel@lists.openezx.org>"
+LICENSE = "GPL"
+PV = "0.2.0+svnr${SRCREV}"
-DEFAULT_PREFERENCE = "-1"
+SRC_URI = "svn://svn.openezx.org/trunk/src/host;module=boot_usb;proto=http"
+S = "${WORKDIR}/boot_usb"
-PV = "0.2.0+r${SRCREV}"
+EXTRA_OECONF := '--with-kernel-dir="${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"'
+
+inherit autotools native
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 boot_usb ${DEPLOY_DIR_TOOLS}/ezx-boot-usb-${PV}
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+
+addtask deploy before do_build after do_compile