summaryrefslogtreecommitdiff
path: root/packages/efl
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-28 14:09:12 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-28 14:09:12 +0000
commit16c391e5fb0d4636a13dcc3df5c61409afbf4816 (patch)
treec8d1733e5ee3c755b0dc2ca27c5fc4872da412a5 /packages/efl
parent2d6d93f92a3f6f2aae2a88fc81659e37ea2768e7 (diff)
efl: add feature-reduced set of esmart that builds without X and split esmart into -fb and -x11 variants
Diffstat (limited to 'packages/efl')
-rw-r--r--packages/efl/esmart-fb_0.9.0.004.bb18
-rw-r--r--packages/efl/esmart-x11_0.9.0.004.bb (renamed from packages/efl/esmart_0.9.0.004.bb)22
-rw-r--r--packages/efl/esmart.inc43
-rw-r--r--packages/efl/esmart/disable-x-only-features.patch24
4 files changed, 86 insertions, 21 deletions
diff --git a/packages/efl/esmart-fb_0.9.0.004.bb b/packages/efl/esmart-fb_0.9.0.004.bb
new file mode 100644
index 0000000000..35bef239ee
--- /dev/null
+++ b/packages/efl/esmart-fb_0.9.0.004.bb
@@ -0,0 +1,18 @@
+include esmart.inc
+PR = "r0"
+
+SRC_URI += "file://disable-x-only-features.patch;patch=1"
+
+myheaders = "esmart_container/Esmart_Container.h \
+ esmart_draggies/Esmart_Draggies.h \
+ esmart_file_dialog/Esmart_File_Dialog.h \
+ esmart_text_entry/Esmart_Text_Entry.h \
+ esmart_textarea/Esmart_Textarea.h \
+ esmart_thumb/Esmart_Thumb.h"
+
+mylibraries = "esmart_container \
+ esmart_draggies \
+ esmart_file_dialog \
+ esmart_text_entry \
+ esmart_textarea \
+ esmart_thumb"
diff --git a/packages/efl/esmart_0.9.0.004.bb b/packages/efl/esmart-x11_0.9.0.004.bb
index c68b78aeb9..a7c9f97584 100644
--- a/packages/efl/esmart_0.9.0.004.bb
+++ b/packages/efl/esmart-x11_0.9.0.004.bb
@@ -1,15 +1,6 @@
-DESCRIPTION = "ESmart is a collection of smart Evas objects"
-LICENSE = "MIT"
-DEPENDS = "evas-x11 ecore-x11 virtual/imlib2 epsilon edje libtool"
+include esmart.inc
PR = "r2"
-inherit efl
-
-SRC_URI += "file://compile-fix.patch;patch=1"
-
-headers = ""
-libraries = ""
-
myheaders = "esmart_container/Esmart_Container.h \
esmart_draggies/Esmart_Draggies.h \
esmart_file_dialog/Esmart_File_Dialog.h \
@@ -25,14 +16,3 @@ mylibraries = "esmart_container \
esmart_textarea \
esmart_thumb \
esmart_trans_x11"
-
-do_stage_append() {
- install -d ${STAGING_INCDIR}/Esmart/
- for i in ${myheaders}; do
- install -m 0644 ${S}/src/lib/$i ${STAGING_INCDIR}/Esmart/
- done
- oe_libinstall -C src/lib libsmart ${STAGING_LIBDIR}/
- for i in ${mylibraries}; do
- oe_libinstall -C src/lib/$i lib$i ${STAGING_LIBDIR}/
- done
-}
diff --git a/packages/efl/esmart.inc b/packages/efl/esmart.inc
new file mode 100644
index 0000000000..452222e93b
--- /dev/null
+++ b/packages/efl/esmart.inc
@@ -0,0 +1,43 @@
+DESCRIPTION = "ESmart is a collection of smart Evas objects"
+LICENSE = "MIT"
+DEPENDS = "virtual/evas virtual/ecore virtual/imlib2 epsilon edje libtool"
+
+inherit efl
+
+SRC_URI = "http://enlightenment.freedesktop.org/files/esmart-${PV}.tar.gz \
+ file://compile-fix.patch;patch=1"
+S = "${WORKDIR}/esmart-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/esmart"
+
+headers = ""
+libraries = ""
+
+myheaders = "<override me>"
+mylibraries = "<override me>"
+
+do_stage_append() {
+ install -d ${STAGING_INCDIR}/Esmart/
+ for i in ${myheaders}; do
+ install -m 0644 ${S}/src/lib/$i ${STAGING_INCDIR}/Esmart/
+ done
+ oe_libinstall -C src/lib libsmart ${STAGING_LIBDIR}/
+ for i in ${mylibraries}; do
+ oe_libinstall -C src/lib/$i lib$i ${STAGING_LIBDIR}/
+ done
+}
+
+PACKAGES =+ "libesmart-textentry \
+ libesmart-thumb \
+ libesmart-container \
+ libesmart-container-plugins \
+ libesmart-file-dialog \
+ libesmart-draggies \
+ libesmart-trans-x11"
+FILES_libesmart-textentry = "${libdir}/libesmart_text_entry*.so*"
+FILES_libesmart-thumb = "${libdir}/libesmart_thumb*.so*"
+FILES_libesmart-container = "${libdir}/libesmart_container*"
+DEPENDS_libesmart-container += "libesmart-container-plugins"
+FILES_libesmart-container-plugins = "${libdir}/esmart/layout/*.so"
+FILES_libesmart-file-dialog = "${libdir}/libesmart_file_dialog*.so*"
+FILES_libesmart-draggies = "${libdir}/libesmart_draggies*.so*"
+FILES_libesarmt-trans-x11 = "${libdir}/libesmart_trans_x11*.so*"
diff --git a/packages/efl/esmart/disable-x-only-features.patch b/packages/efl/esmart/disable-x-only-features.patch
new file mode 100644
index 0000000000..54638841ee
--- /dev/null
+++ b/packages/efl/esmart/disable-x-only-features.patch
@@ -0,0 +1,24 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- esmart-0.9.0.004/src/lib/Makefile.am~disable-x-only-features.patch
++++ esmart-0.9.0.004/src/lib/Makefile.am
+@@ -1,8 +1,5 @@
+ SUBDIRS = \
+ esmart_container \
+- esmart_draggies \
+ esmart_text_entry \
+ esmart_file_dialog \
+- esmart_thumb \
+- esmart_trans_x11 \
+- esmart_textarea
++ esmart_thumb
+--- esmart-0.9.0.004/src/Makefile.am~disable-x-only-features.patch
++++ esmart-0.9.0.004/src/Makefile.am
+@@ -1,3 +1,3 @@
+ MAINTAINERCLEANFILES = Makefile.in
+
+-SUBDIRS = lib bin
++SUBDIRS = lib