summaryrefslogtreecommitdiff
path: root/packages/efl1/evas-native_cvs.bb
diff options
context:
space:
mode:
authorRodrigo Vivi <rodrigo.vivi@gmail.com>2008-03-27 18:45:00 +0000
committerRodrigo Vivi <rodrigo.vivi@gmail.com>2008-03-27 18:45:00 +0000
commitbab0bc1011c17ac35ac7499b3db23fa85419e05f (patch)
tree26fe87bc48e130d6f1b1a0c1c990622c1c48d63c /packages/efl1/evas-native_cvs.bb
parente3ba7f3f4a1345008ca97eab8663150fb00b10da (diff)
parent6775017f8db3583d4166f48f937bc339b97d0b35 (diff)
merge of '487f86d7da4356e5d8c6832b7ff5f0ee9ab8c293'
and 'd1dfc5df9769c50ec5328454ab737f091f6c573f'
Diffstat (limited to 'packages/efl1/evas-native_cvs.bb')
-rw-r--r--packages/efl1/evas-native_cvs.bb57
1 files changed, 56 insertions, 1 deletions
diff --git a/packages/efl1/evas-native_cvs.bb b/packages/efl1/evas-native_cvs.bb
index 204abbb821..3ca8df9e41 100644
--- a/packages/efl1/evas-native_cvs.bb
+++ b/packages/efl1/evas-native_cvs.bb
@@ -1,7 +1,7 @@
require evas.inc
inherit native
DEPENDS = "freetype-native libpng-native jpeg-native eet-native"
-PR = "r0"
+PR = "r1"
EXTRA_OECONF = "\
--x-includes=${STAGING_INCDIR}/X11 \
@@ -59,3 +59,58 @@ EXTRA_OECONF = "\
--disable-convert-32-rgb-rot-90 \
--disable-convert-32-rgb-rot-270"
+
+# evas needs a different oe_libinstall, so copy/paste autotools_stage_all
+do_stage() {
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install
+ autotools_stage_dir ${STAGE_TEMP}/${includedir} ${STAGING_INCDIR}
+ if [ "${BUILD_SYS}" = "${HOST_SYS}" ]; then
+ autotools_stage_dir ${STAGE_TEMP}/${bindir} ${STAGING_DIR_HOST}${layout_bindir}
+ autotools_stage_dir ${STAGE_TEMP}/${sbindir} ${STAGING_DIR_HOST}${layout_sbindir}
+ autotools_stage_dir ${STAGE_TEMP}/${base_bindir} ${STAGING_DIR_HOST}${layout_base_bindir}
+ autotools_stage_dir ${STAGE_TEMP}/${base_sbindir} ${STAGING_DIR_HOST}${layout_base_sbindir}
+ autotools_stage_dir ${STAGE_TEMP}/${libexecdir} ${STAGING_DIR_HOST}${layout_libexecdir}
+ fi
+ if [ -d ${STAGE_TEMP}/${libdir} ]
+ then
+ olddir=`pwd`
+ cd ${STAGE_TEMP}/${libdir}
+ las=$(find . -name \*.la -type f)
+ cd $olddir
+ echo "Found la files: $las"
+ if [ -n "$las" ]; then
+ # If there are .la files then libtool was used in the
+ # build, so install them with magic mangling.
+ for i in $las
+ do
+ dir=$(dirname $i)
+ echo "oe_libinstall -C ${STAGE_TEMP}/${libdir}/${dir} -so $(basename $i .la) ${STAGING_LIBDIR}/${dir}"
+ oe_libinstall -C ${STAGE_TEMP}/${libdir}/${dir} -so $(basename $i .la) ${STAGING_LIBDIR}/${dir}
+ done
+ else
+ # Otherwise libtool wasn't used, and lib/ can be copied
+ # directly.
+ echo "cp -fpPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}"
+ cp -fpPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
+ fi
+
+ fi
+ # Ok, this is nasty. pkgconfig.bbclass is usually used to install .pc files,
+ # however some packages rely on the presence of .pc files to enable/disable
+ # their configurataions in which case we better should not install everything
+ # unconditionally, but rather depend on the actual results of make install.
+ # The good news though: a) there are not many packages doing this and
+ # b) packaged staging will fix that anyways. :M:
+ if [ "${AUTOTOOLS_STAGE_PKGCONFIG}" = "1" ]
+ then
+ echo "cp -f ${STAGE_TEMP}/${libdir}/pkgconfig/*.pc ${STAGING_LIBDIR}/pkgconfig/"
+ cp -f ${STAGE_TEMP}/${libdir}/pkgconfig/*.pc ${STAGING_LIBDIR}/pkgconfig/
+ fi
+ rm -rf ${STAGE_TEMP}/${mandir} || true
+ rm -rf ${STAGE_TEMP}/${infodir} || true
+ autotools_stage_dir ${STAGE_TEMP}/${datadir} ${STAGING_DATADIR}
+ rm -rf ${STAGE_TEMP}
+
+}