summaryrefslogtreecommitdiff
path: root/packages/efl/ewl_0.5.1.008.bb
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2007-06-01 23:29:44 +0000
committerMatthias Hentges <oe@hentges.net>2007-06-01 23:29:44 +0000
commitee46004e7812188b6f432d87ebdb41a18d120d57 (patch)
tree381c6eff6ac25bceb3e6823922fbf9282a13f5d7 /packages/efl/ewl_0.5.1.008.bb
parentcf211746683f39d1fb0c7a02771a0c9a8003f59a (diff)
parenta1b84ca79c1cd61dd5b2563104e69723070a6108 (diff)
merge of '29262672242dce33a5d94bf91091b9a5a7ea7621'
and '9f671f6c3a17dbd8450e267353cf95d120238e50'
Diffstat (limited to 'packages/efl/ewl_0.5.1.008.bb')
-rw-r--r--packages/efl/ewl_0.5.1.008.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/efl/ewl_0.5.1.008.bb b/packages/efl/ewl_0.5.1.008.bb
new file mode 100644
index 0000000000..3a9313cb59
--- /dev/null
+++ b/packages/efl/ewl_0.5.1.008.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "The Enlightened Widget Library, \
+a simple-to-use general purpose widget library based on the enlightenment foundation libraries."
+DEPENDS = "edb virtual/evas virtual/ecore edje"
+# emotion
+RDEPENDS += "ewl-themes"
+LICENSE = "MIT"
+PR = "r1"
+
+inherit efl
+
+SRC_URI += "file://ewl-configure.patch;patch=1 \
+ file://no-examples.patch;patch=1 \
+ file://minmax.patch;patch=1 \
+ ${E_CVS};module=e17/libs/evas/m4;date=20060501"
+
+do_configure_prepend() {
+ if [ -e "${WORKDIR}/m4" ]; then
+ install -d "${S}/m4"
+ install "${WORKDIR}/m4/"*.m4 "${S}/m4"
+ aclocal -I m4
+ fi
+}
+
+do_stage_append() {
+ for i in src/lib/ewl_*.h
+ do
+ install -m 0644 $i ${STAGING_INCDIR}
+ done
+}