summaryrefslogtreecommitdiff
path: root/packages/efl/ewl_0.0.4.005.bb
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2006-02-05 05:26:43 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-05 05:26:43 +0000
commitaea7a790f3a96a488c6197cacb26707fbbda16a4 (patch)
treefd2d36d0c071f4e320446176ac91070393aa0739 /packages/efl/ewl_0.0.4.005.bb
parent19f3fb04fe976bf96329356ea2209e92e8827a21 (diff)
parent7012a444f57bcb44f0ee6326ea02efa6a2bb09a5 (diff)
merge of 911d39563f4bbb32b27acb504168de96ff1e68f7
and c6e9501260c1bb7c2842f36ce47f70045a964179
Diffstat (limited to 'packages/efl/ewl_0.0.4.005.bb')
-rw-r--r--packages/efl/ewl_0.0.4.005.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/efl/ewl_0.0.4.005.bb b/packages/efl/ewl_0.0.4.005.bb
new file mode 100644
index 0000000000..85b85e0c05
--- /dev/null
+++ b/packages/efl/ewl_0.0.4.005.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "The Enlightened Widget Library, \
+a simple-to-use general purpose widget library based on the enlightenment foundation libraries."
+# as of recent CVS HEAD, ewl no longer needs etox and no longer needs edb
+DEPENDS = "edb virtual/evas virtual/ecore edje emotion"
+RDEPENDS += "libewl-themes"
+LICENSE = "MIT"
+PR = "r1"
+
+inherit efl
+
+SRC_URI += "file://ewl-configure.patch;patch=1 \
+ file://fix-ecore.patch;patch=1 \
+ file://ecore-flags.patch;patch=1 \
+ file://no-examples.patch;patch=1 \
+ file://minmax.patch;patch=1"
+
+do_stage_append() {
+ for i in src/lib/ewl_*.h
+ do
+ install -m 0644 $i ${STAGING_INCDIR}
+ done
+}
+