summaryrefslogtreecommitdiff
path: root/packages/efl/ewl
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-09-30 17:59:20 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-30 17:59:20 +0000
commit7e5e0be1af62584244662daa1989ffd8206c7298 (patch)
tree6eade7dca695f1668a509a7debde9aae887b9ff0 /packages/efl/ewl
parent206647fb6ccf68137a2793c913053579f4553244 (diff)
e17, efl: major upgrade to newer versions
- Upgraded shapshot-based packages to newest released snapshots - Upgraded CVS-based packages to use a newer date - Moved e and e-wm to use snapshots as a default instead of CVS - Updated patches to work with newer versions - Added patches to fix problems introduced in newer versions - Added a patch to disable the splash for e-wm (causes a segfault) - entrance now uses ecore_config instead of edb - Added pulling of m4 directories for a few packages and running of aclocal due to autotools problems - elitaire currently does not compile, removed from e-image
Diffstat (limited to 'packages/efl/ewl')
-rw-r--r--packages/efl/ewl/ecore-flags.patch146
-rw-r--r--packages/efl/ewl/fix-ecore.patch11
-rw-r--r--packages/efl/ewl/minmax.patch18
-rw-r--r--packages/efl/ewl/no-examples.patch22
4 files changed, 197 insertions, 0 deletions
diff --git a/packages/efl/ewl/ecore-flags.patch b/packages/efl/ewl/ecore-flags.patch
new file mode 100644
index 0000000000..9c4f5afc78
--- /dev/null
+++ b/packages/efl/ewl/ecore-flags.patch
@@ -0,0 +1,146 @@
+diff -Nur ewl-0.0.4.004~/src/lib/ewl_config.c ewl-0.0.4.004/src/lib/ewl_config.c
+--- ewl-0.0.4.004~/src/lib/ewl_config.c 2005-09-29 18:02:24.000000000 -0700
++++ ewl-0.0.4.004/src/lib/ewl_config.c 2005-09-29 18:03:10.000000000 -0700
+@@ -210,8 +210,8 @@
+
+ cc = ewl_config_int_get("/ewl/theme/color_classes/count");
+ prop = ecore_config_get("/ewl/theme/color_classes/count");
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ for (i = 0; i < cc; i++) {
+ char *name;
+@@ -221,8 +221,8 @@
+ "/ewl/theme/color_classes/%d/name", i);
+ name = ewl_config_str_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ if (name) {
+ int r, g, b, a;
+@@ -233,85 +233,85 @@
+ "/ewl/theme/color_classes/%d/r", i);
+ r = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ snprintf(key, PATH_MAX,
+ "/ewl/theme/color_classes/%d/g", i);
+ g = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ snprintf(key, PATH_MAX,
+ "/ewl/theme/color_classes/%d/b", i);
+ b = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ snprintf(key, PATH_MAX,
+ "/ewl/theme/color_classes/%d/a", i);
+ a = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ snprintf(key, PATH_MAX,
+ "/ewl/theme/color_classes/%d/r2", i);
+ r2 = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ snprintf(key, PATH_MAX,
+ "/ewl/theme/color_classes/%d/g2", i);
+ g2 = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ snprintf(key, PATH_MAX,
+ "/ewl/theme/color_classes/%d/b2", i);
+ b2 = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ snprintf(key, PATH_MAX,
+ "/ewl/theme/color_classes/%d/a2", i);
+ a2 = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ snprintf(key, PATH_MAX,
+ "/ewl/theme/color_classes/%d/r3", i);
+ r3 = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ snprintf(key, PATH_MAX,
+ "/ewl/theme/color_classes/%d/g3", i);
+ g3 = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ snprintf(key, PATH_MAX,
+ "/ewl/theme/color_classes/%d/b3", i);
+ b3 = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ snprintf(key, PATH_MAX,
+ "/ewl/theme/color_classes/%d/a3", i);
+ a3 = ewl_config_int_get(key);
+ prop = ecore_config_get(key);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+
+ edje_color_class_set(name, r, g, b, a,
+ r2, g2, b2, a2,
+@@ -389,8 +389,8 @@
+
+ for(i = 0; keys[i] != NULL; i++) {
+ prop = ecore_config_get(keys[i]);
+- prop->flags &= ~PF_MODIFIED;
+- prop->flags |= PF_SYSTEM;
++ prop->flags &= ~ECORE_CONFIG_FLAG_MODIFIED;
++ prop->flags |= ECORE_CONFIG_FLAG_SYSTEM;
+ }
+
+ ecore_config_listen("ewl_debug_enable", "/ewl/debug/enable",
diff --git a/packages/efl/ewl/fix-ecore.patch b/packages/efl/ewl/fix-ecore.patch
new file mode 100644
index 0000000000..7a514a1740
--- /dev/null
+++ b/packages/efl/ewl/fix-ecore.patch
@@ -0,0 +1,11 @@
+diff -Nur ewl-0.0.4.004~/src/lib/Ewl.h ewl-0.0.4.004/src/lib/Ewl.h
+--- ewl-0.0.4.004~/src/lib/Ewl.h.in 2005-09-29 17:44:59.000000000 -0700
++++ ewl-0.0.4.004/src/lib/Ewl.h.in 2005-09-29 17:46:57.000000000 -0700
+@@ -257,6 +257,7 @@
+ #include <Evas.h>
+ #include <Edje.h>
+ #include <Ecore.h>
++#include <Ecore_Data.h>
+ #include <Edb.h>
+
+ #include <stdio.h>
diff --git a/packages/efl/ewl/minmax.patch b/packages/efl/ewl/minmax.patch
new file mode 100644
index 0000000000..cd8723e9a3
--- /dev/null
+++ b/packages/efl/ewl/minmax.patch
@@ -0,0 +1,18 @@
+diff -Nur ewl-0.0.4.004~/src/lib/Ewl.h.in ewl-0.0.4.004/src/lib/Ewl.h.in
+--- ewl-0.0.4.004~/src/lib/Ewl.h.in 2005-09-29 18:26:11.000000000 -0700
++++ ewl-0.0.4.004/src/lib/Ewl.h.in 2005-09-29 18:26:55.000000000 -0700
+@@ -254,6 +254,14 @@
+ extern"C" {
+ #endif
+
++#ifndef MAX
++#define MAX(a, b) (a > b ? a : b)
++#endif
++
++#ifndef MIN
++#define MIN(a, b) (a < b ? a : b)
++#endif
++
+ #include <Evas.h>
+ #include <Edje.h>
+ #include <Ecore.h>
diff --git a/packages/efl/ewl/no-examples.patch b/packages/efl/ewl/no-examples.patch
new file mode 100644
index 0000000000..402c50894c
--- /dev/null
+++ b/packages/efl/ewl/no-examples.patch
@@ -0,0 +1,22 @@
+diff -Nur ewl-0.0.4.004~/src/Makefile.am ewl-0.0.4.004/src/Makefile.am
+--- ewl-0.0.4.004~/src/Makefile.am 2005-09-29 18:21:52.000000000 -0700
++++ ewl-0.0.4.004/src/Makefile.am 2005-09-29 18:22:17.000000000 -0700
+@@ -1,5 +1,5 @@
+
+-SUBDIRS = lib bin
++SUBDIRS = lib
+
+ MAINTAINERCLEANFILES = Makefile.in
+
+diff -Nur ewl-0.0.4.004~/src/Makefile.in ewl-0.0.4.004/src/Makefile.in
+--- ewl-0.0.4.004~/src/Makefile.in 2005-09-29 18:21:52.000000000 -0700
++++ ewl-0.0.4.004/src/Makefile.in 2005-09-29 18:22:07.000000000 -0700
+@@ -108,7 +108,7 @@
+ ewl_media_include = @ewl_media_include@
+ requirements = @requirements@
+
+-SUBDIRS = lib bin
++SUBDIRS = lib
+
+ MAINTAINERCLEANFILES = Makefile.in
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs