summaryrefslogtreecommitdiff
path: root/packages/efl/evas/fix-configure.patch
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-08-11 20:20:21 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-11 20:20:21 +0000
commit070e75b9c6cc865471ae4bded62e3cc958f41d51 (patch)
tree31356a12bb0b8dede8632fc9056baf26d775a6d3 /packages/efl/evas/fix-configure.patch
parent2acf28fb2e382351b774326eff393e1f93df92e8 (diff)
parentbece5b20b67cbd731804da824758eda49875eef9 (diff)
propagate from branch 'org.openembedded.dev' (head af7da4406babf078f2747a3588cfa451ae711315)
to branch 'org.openembedded.nslu2-linux' (head 99bf568313454a05bf17df79cb135d7e4bb6c643)
Diffstat (limited to 'packages/efl/evas/fix-configure.patch')
-rw-r--r--packages/efl/evas/fix-configure.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/packages/efl/evas/fix-configure.patch b/packages/efl/evas/fix-configure.patch
new file mode 100644
index 0000000000..cc7462e72c
--- /dev/null
+++ b/packages/efl/evas/fix-configure.patch
@@ -0,0 +1,49 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- evas-0.9.9.013/configure.in~fix-configure
++++ evas-0.9.9.013/configure.in
+@@ -157,9 +157,7 @@
+ [
+ AM_CONDITIONAL(BUILD_ENGINE_SOFTWARE_X11, true)
+ AC_DEFINE(BUILD_ENGINE_SOFTWARE_X11, 1, [Software X11 Rendering Backend])
+- x_dir=${x_dir:-/usr/X11R6}
+- x_cflags=${x_cflags:--I${x_includes:-$x_dir/include}}
+- x_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} -lX11 -lXext"
++ x_libs="-lX11 -lXext";
+ ENGINE_SOFTWARE_X11_PRG="evas_software_x11_test evas_software_x11_perf_test evas_software_x11_perf_load"
+ ],
+ [
+@@ -221,7 +219,7 @@
+ X11/X.h,
+ [AM_CONDITIONAL(BUILD_ENGINE_SOFTWARE_XCB, true)
+ AC_DEFINE(BUILD_ENGINE_SOFTWARE_XCB, 1, [Software XCB Rendering Backend])
+- xcb_dir=${x_dir:-/usr/X11R6}
++ xcb_dir=${x_dir:-}
+ xcb_cflags="${x_cflags:--I${x_includes:-$x_dir/include}} $XCB_CFLAGS $XCB_ICCCM_CFLAGS"
+ xcb_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} $XCB_LIBS $XCB_ICCCM_LIBS"
+ ENGINE_SOFTWARE_XCB_PRG="evas_software_xcb_test evas_software_xcb_perf_test evas_software_xcb_perf_load"],
+@@ -433,10 +431,10 @@
+ AC_DEFINE(BUILD_ENGINE_GL_X11, 1, [OpenGL X11 Rendering Backend])
+ AM_CONDITIONAL(BUILD_ENGINE_GL_COMMON, true)
+ AC_DEFINE(BUILD_ENGINE_GL_COMMON, 1, [Generic OpenGL Rendering Support])
+- x_dir=${x_dir:-/usr/X11R6};
++ x_dir=${x_dir:-};
+ x_cflags=${x_cflags:--I$x_dir/include}
+ x_libs="${x_libs:--L$x_dir/lib -lX11 -lXext}"
+- gl_cflags="-I/usr/include"
++ gl_cflags=""
+ gl_libs="-lGL -lGLU -lpthread"
+ gl_dir=""
+ ENGINE_GL_X11_PRG="evas_gl_x11_test"
+@@ -490,7 +488,7 @@
+ AC_DEFINE(BUILD_ENGINE_CAIRO_X11, 1, [Cairo X11 Rendering Backend])
+ AM_CONDITIONAL(BUILD_ENGINE_CAIRO_COMMON, true)
+ AC_DEFINE(BUILD_ENGINE_CAIRO_COMMON, 1, [Generic Cairo Rendering Support])
+- x_dir="/usr/X11R6";
++ x_dir="";
+ x_cflags="-I"$x_dir"/include"
+ x_libs="-L"$x_dir"/lib -lX11 -lXext"
+ ENGINE_CAIRO_X11_PRG="evas_cairo_x11_test"