summaryrefslogtreecommitdiff
path: root/packages/efl/evas/fix-configure-20060113.patch
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2006-02-05 05:26:43 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-05 05:26:43 +0000
commitaea7a790f3a96a488c6197cacb26707fbbda16a4 (patch)
treefd2d36d0c071f4e320446176ac91070393aa0739 /packages/efl/evas/fix-configure-20060113.patch
parent19f3fb04fe976bf96329356ea2209e92e8827a21 (diff)
parent7012a444f57bcb44f0ee6326ea02efa6a2bb09a5 (diff)
merge of 911d39563f4bbb32b27acb504168de96ff1e68f7
and c6e9501260c1bb7c2842f36ce47f70045a964179
Diffstat (limited to 'packages/efl/evas/fix-configure-20060113.patch')
-rw-r--r--packages/efl/evas/fix-configure-20060113.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/packages/efl/evas/fix-configure-20060113.patch b/packages/efl/evas/fix-configure-20060113.patch
new file mode 100644
index 0000000000..acd50c0282
--- /dev/null
+++ b/packages/efl/evas/fix-configure-20060113.patch
@@ -0,0 +1,45 @@
+diff -Nur evas-0.9.9.015~/configure.in evas-0.9.9.015/configure.in
+--- evas-0.9.9.015~/configure.in 2005-09-28 15:12:03.000000000 -0700
++++ evas-0.9.9.015/configure.in 2005-09-28 15:13:05.000000000 -0700
+@@ -152,9 +152,7 @@
+ [
+ AM_CONDITIONAL(BUILD_ENGINE_SOFTWARE_X11, true)
+ AC_DEFINE(BUILD_ENGINE_SOFTWARE_X11, 1, [Software X11 Rendering Backend])
+- x_dir=${x_dir:-/usr/X11R6}
+- x_cflags=${x_cflags:--I${x_includes:-$x_dir/include}}
+- x_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} -lX11 -lXext"
++ x_libs="-lX11 -lXext";
+ ENGINE_SOFTWARE_X11_PRG="evas_software_x11_test evas_software_x11_perf_test evas_software_x11_perf_load"
+ ],
+ [
+@@ -216,7 +214,7 @@
+ X11/X.h,
+ [AM_CONDITIONAL(BUILD_ENGINE_SOFTWARE_XCB, true)
+ AC_DEFINE(BUILD_ENGINE_SOFTWARE_XCB, 1, [Software XCB Rendering Backend])
+- xcb_dir=${x_dir:-/usr/X11R6}
++ xcb_dir=${x_dir:-}
+ xcb_cflags="${x_cflags:--I${x_includes:-$x_dir/include}} $XCB_CFLAGS $XCB_ICCCM_CFLAGS"
+ xcb_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} $XCB_LIBS $XCB_ICCCM_LIBS"
+ ENGINE_SOFTWARE_XCB_PRG="evas_software_xcb_test evas_software_xcb_perf_test evas_software_xcb_perf_load"],
+@@ -430,10 +428,10 @@
+ AC_DEFINE(BUILD_ENGINE_GL_X11, 1, [OpenGL X11 Rendering Backend])
+ AM_CONDITIONAL(BUILD_ENGINE_GL_COMMON, true)
+ AC_DEFINE(BUILD_ENGINE_GL_COMMON, 1, [Generic OpenGL Rendering Support])
+- x_dir=${x_dir:-/usr/X11R6};
++ x_dir=${x_dir:-};
+ x_cflags=${x_cflags:--I$x_dir/include}
+ x_libs="${x_libs:--L$x_dir/lib -lX11 -lXext}"
+- gl_cflags="-I/usr/include"
++ gl_cflags=""
+ gl_libs="-lGL -lGLU -lpthread"
+ gl_dir=""
+ ENGINE_GL_X11_PRG="evas_gl_x11_test"
+@@ -496,7 +494,7 @@
+ AC_DEFINE(BUILD_ENGINE_CAIRO_X11, 1, [Cairo X11 Rendering Backend])
+ AM_CONDITIONAL(BUILD_ENGINE_CAIRO_COMMON, true)
+ AC_DEFINE(BUILD_ENGINE_CAIRO_COMMON, 1, [Generic Cairo Rendering Support])
+- x_dir="/usr/X11R6";
++ x_dir="";
+ x_cflags="-I"$x_dir"/include"
+ x_libs="-L"$x_dir"/lib -lX11 -lXext"
+ ENGINE_CAIRO_X11_PRG="evas_cairo_x11_test"