summaryrefslogtreecommitdiff
path: root/packages/efl/engrave_20050926.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-09-30 17:59:20 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-30 17:59:20 +0000
commit7e5e0be1af62584244662daa1989ffd8206c7298 (patch)
tree6eade7dca695f1668a509a7debde9aae887b9ff0 /packages/efl/engrave_20050926.bb
parent206647fb6ccf68137a2793c913053579f4553244 (diff)
e17, efl: major upgrade to newer versions
- Upgraded shapshot-based packages to newest released snapshots - Upgraded CVS-based packages to use a newer date - Moved e and e-wm to use snapshots as a default instead of CVS - Updated patches to work with newer versions - Added patches to fix problems introduced in newer versions - Added a patch to disable the splash for e-wm (causes a segfault) - entrance now uses ecore_config instead of edb - Added pulling of m4 directories for a few packages and running of aclocal due to autotools problems - elitaire currently does not compile, removed from e-image
Diffstat (limited to 'packages/efl/engrave_20050926.bb')
-rw-r--r--packages/efl/engrave_20050926.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/efl/engrave_20050926.bb b/packages/efl/engrave_20050926.bb
new file mode 100644
index 0000000000..8ee284fb19
--- /dev/null
+++ b/packages/efl/engrave_20050926.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Engrave is an Edje Editing Library"
+LICENSE = "MIT"
+# also requires yacc and lex on host
+DEPENDS = "virtual/evas virtual/ecore"
+
+inherit efl
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/libs/engrave"
+S = "${WORKDIR}/engrave"
+
+do_stage_append() {
+ for i in src/lib/engrave*.h
+ do
+ install -m 0644 $i ${STAGING_INCDIR}
+ done
+}
+