summaryrefslogtreecommitdiff
path: root/packages/efl/edje-native_0.5.0.025.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-04-04 09:27:59 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-04 09:27:59 +0000
commit414a70ace8cf06857958fad7f87cfcb63b350072 (patch)
tree71a0005a35f07b5273ebfe337783e692c3262c0a /packages/efl/edje-native_0.5.0.025.bb
parent2444331e2870baa9e5bf3978571cc7fc06cd13c7 (diff)
parent6ce3ce8860572954d283d4ec66364875d66a6d9c (diff)
merge of 85a1c1efe7466253130cd2e2a63079154ba54454
and c67d38b84a548cc9efa81f9371658f5c59e87e43
Diffstat (limited to 'packages/efl/edje-native_0.5.0.025.bb')
-rw-r--r--packages/efl/edje-native_0.5.0.025.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/efl/edje-native_0.5.0.025.bb b/packages/efl/edje-native_0.5.0.025.bb
new file mode 100644
index 0000000000..5e7bed336d
--- /dev/null
+++ b/packages/efl/edje-native_0.5.0.025.bb
@@ -0,0 +1,29 @@
+include edje_${PV}.bb
+PR = "r2"
+
+REAL_TARGET_SYS := ${TARGET_SYS}
+
+inherit native
+DEPENDS = "evas-native ecore-native eet-native embryo-native imlib2-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/edje"
+
+EXTRA_OECONF = "--with-evas-config=${STAGING_BINDIR}/evas-config-native \
+ --with-ecore-config=${STAGING_BINDIR}/ecore-config-native \
+ --with-eet-config=${STAGING_BINDIR}/eet-config-native \
+ --with-embryo-config=${STAGING_BINDIR}/embryo-config-native \
+ --with-imlib2-config=${STAGING_BINDIR}/imlib2-config-native "
+
+do_configure_prepend() {
+ sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
+# sed -i 's:/usr/bin/cpp:${STAGING_DIR}/cross/bin/${REAL_TARGET_SYS}-cpp:' ${S}/src/bin/edje_cc_parse.c
+# sed -i 's:/usr/bin/gcc:${STAGING_DIR}/cross/bin/${REAL_TARGET_SYS}-gcc:' ${S}/src/bin/edje_cc_parse.c
+ sed -i 's:cpp -I:/usr/bin/cpp -I:' ${S}/src/bin/edje_cc_parse.c
+ sed -i 's:gcc -I:/usr/bin/gcc -I:' ${S}/src/bin/edje_cc_parse.c
+}
+
+do_stage_append() {
+ edje_data_dir=`${STAGING_BINDIR}/edje-config-native --datadir`
+ # could also use ${STAGING_DATADIR}/edje/include
+ install -d $edje_data_dir/include
+ install -m 0644 data/include/edje.inc $edje_data_dir/include
+}