summaryrefslogtreecommitdiff
path: root/packages/efl/edje-native_0.5.0.023.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-02-06 18:36:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-06 18:36:28 +0000
commit5c70d86825ced73fe07d02a4647e70c54f2efe07 (patch)
tree23b7b80934d3f7d54d036bfa71c7ffae68dd169b /packages/efl/edje-native_0.5.0.023.bb
parent11ec8ab68be596ed8fca854042f2e8815da19ce2 (diff)
parentedab0569b271a6c11d611afcdeb3f8a5a3a682e6 (diff)
merge of 87274db5332eba6f472a3332129b88b8282ccda2
and 3b6a0bff32c9c79ebeb059cd1559d7731542af03
Diffstat (limited to 'packages/efl/edje-native_0.5.0.023.bb')
-rw-r--r--packages/efl/edje-native_0.5.0.023.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/efl/edje-native_0.5.0.023.bb b/packages/efl/edje-native_0.5.0.023.bb
new file mode 100644
index 0000000000..44b4e80c20
--- /dev/null
+++ b/packages/efl/edje-native_0.5.0.023.bb
@@ -0,0 +1,30 @@
+include edje_${PV}.bb
+PR = "r2"
+
+REAL_TARGET_SYS := ${TARGET_SYS}
+
+inherit native
+DEPENDS = "evas-native ecore-native eet-native embryo-native imlib2-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/edje"
+
+EXTRA_OECONF = "--with-fb-only \
+ --with-evas-config=${STAGING_BINDIR}/evas-config-native \
+ --with-ecore-config=${STAGING_BINDIR}/ecore-config-native \
+ --with-eet-config=${STAGING_BINDIR}/eet-config-native \
+ --with-embryo-config=${STAGING_BINDIR}/embryo-config-native \
+ --with-imlib2-config=${STAGING_BINDIR}/imlib2-config-native "
+
+do_configure_prepend() {
+ sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
+# sed -i 's:/usr/bin/cpp:${STAGING_DIR}/cross/bin/${REAL_TARGET_SYS}-cpp:' ${S}/src/bin/edje_cc_parse.c
+# sed -i 's:/usr/bin/gcc:${STAGING_DIR}/cross/bin/${REAL_TARGET_SYS}-gcc:' ${S}/src/bin/edje_cc_parse.c
+ sed -i 's:cpp -I:/usr/bin/cpp -I:' ${S}/src/bin/edje_cc_parse.c
+ sed -i 's:gcc -I:/usr/bin/gcc -I:' ${S}/src/bin/edje_cc_parse.c
+}
+
+do_stage_append() {
+ edje_data_dir=`${STAGING_BINDIR}/edje-config-native --datadir`
+ # could also use ${STAGING_DATADIR}/edje/include
+ install -d $edje_data_dir/include
+ install -m 0644 data/include/edje.inc $edje_data_dir/include
+}