summaryrefslogtreecommitdiff
path: root/packages/efl/edje-native_0.5.0.023.bb
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2006-02-05 05:26:43 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-05 05:26:43 +0000
commitaea7a790f3a96a488c6197cacb26707fbbda16a4 (patch)
treefd2d36d0c071f4e320446176ac91070393aa0739 /packages/efl/edje-native_0.5.0.023.bb
parent19f3fb04fe976bf96329356ea2209e92e8827a21 (diff)
parent7012a444f57bcb44f0ee6326ea02efa6a2bb09a5 (diff)
merge of 911d39563f4bbb32b27acb504168de96ff1e68f7
and c6e9501260c1bb7c2842f36ce47f70045a964179
Diffstat (limited to 'packages/efl/edje-native_0.5.0.023.bb')
-rw-r--r--packages/efl/edje-native_0.5.0.023.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/efl/edje-native_0.5.0.023.bb b/packages/efl/edje-native_0.5.0.023.bb
new file mode 100644
index 0000000000..44b4e80c20
--- /dev/null
+++ b/packages/efl/edje-native_0.5.0.023.bb
@@ -0,0 +1,30 @@
+include edje_${PV}.bb
+PR = "r2"
+
+REAL_TARGET_SYS := ${TARGET_SYS}
+
+inherit native
+DEPENDS = "evas-native ecore-native eet-native embryo-native imlib2-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/edje"
+
+EXTRA_OECONF = "--with-fb-only \
+ --with-evas-config=${STAGING_BINDIR}/evas-config-native \
+ --with-ecore-config=${STAGING_BINDIR}/ecore-config-native \
+ --with-eet-config=${STAGING_BINDIR}/eet-config-native \
+ --with-embryo-config=${STAGING_BINDIR}/embryo-config-native \
+ --with-imlib2-config=${STAGING_BINDIR}/imlib2-config-native "
+
+do_configure_prepend() {
+ sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
+# sed -i 's:/usr/bin/cpp:${STAGING_DIR}/cross/bin/${REAL_TARGET_SYS}-cpp:' ${S}/src/bin/edje_cc_parse.c
+# sed -i 's:/usr/bin/gcc:${STAGING_DIR}/cross/bin/${REAL_TARGET_SYS}-gcc:' ${S}/src/bin/edje_cc_parse.c
+ sed -i 's:cpp -I:/usr/bin/cpp -I:' ${S}/src/bin/edje_cc_parse.c
+ sed -i 's:gcc -I:/usr/bin/gcc -I:' ${S}/src/bin/edje_cc_parse.c
+}
+
+do_stage_append() {
+ edje_data_dir=`${STAGING_BINDIR}/edje-config-native --datadir`
+ # could also use ${STAGING_DATADIR}/edje/include
+ install -d $edje_data_dir/include
+ install -m 0644 data/include/edje.inc $edje_data_dir/include
+}