summaryrefslogtreecommitdiff
path: root/packages/efl/ecore
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-09-30 17:59:20 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-30 17:59:20 +0000
commit7e5e0be1af62584244662daa1989ffd8206c7298 (patch)
tree6eade7dca695f1668a509a7debde9aae887b9ff0 /packages/efl/ecore
parent206647fb6ccf68137a2793c913053579f4553244 (diff)
e17, efl: major upgrade to newer versions
- Upgraded shapshot-based packages to newest released snapshots - Upgraded CVS-based packages to use a newer date - Moved e and e-wm to use snapshots as a default instead of CVS - Updated patches to work with newer versions - Added patches to fix problems introduced in newer versions - Added a patch to disable the splash for e-wm (causes a segfault) - entrance now uses ecore_config instead of edb - Added pulling of m4 directories for a few packages and running of aclocal due to autotools problems - elitaire currently does not compile, removed from e-image
Diffstat (limited to 'packages/efl/ecore')
-rw-r--r--packages/efl/ecore/configure.patch21
-rw-r--r--packages/efl/ecore/fix-tslib-configure.patch12
2 files changed, 20 insertions, 13 deletions
diff --git a/packages/efl/ecore/configure.patch b/packages/efl/ecore/configure.patch
index a9ae62743d..cd38cb7218 100644
--- a/packages/efl/ecore/configure.patch
+++ b/packages/efl/ecore/configure.patch
@@ -1,27 +1,22 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- ecore-0.9.9.013/configure.in~configure.patch
-+++ ecore-0.9.9.013/configure.in
-@@ -15,7 +15,6 @@
- AC_CHECK_SIZEOF(int, 4)
+diff -Nur ecore-0.9.9.015~/configure.in ecore-0.9.9.015/configure.in
+--- ecore-0.9.9.015~/configure.in 2005-09-26 16:59:23.000000000 -0700
++++ ecore-0.9.9.015/configure.in 2005-09-26 17:01:02.000000000 -0700
+@@ -16,7 +16,6 @@
+ AC_CHECK_SIZEOF(long, 4)
AM_ENABLE_SHARED
AM_PROG_LIBTOOL
-AC_C___ATTRIBUTE__
if test "x${bindir}" = 'x${exec_prefix}/bin'; then
if test "x${exec_prefix}" = "xNONE"; then
-@@ -247,10 +246,8 @@
+@@ -262,9 +261,7 @@
AM_CONDITIONAL(BUILD_ECORE_X, true)
AC_DEFINE(BUILD_ECORE_X, 1, [Build Ecore_X Module])
- BUILD_ECORE_X=1
+ have_ecore_x="yes"
- x_dir=${x_dir:-/usr/X11R6}
- x_cflags=${x_cflags:--I${x_includes:-$x_dir/include}}
- x_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} -lX11 -lXext"
x_ldflags=" "$ecore_x_libs;
-+ x_libs="-lX11 -lXext";
++ x_libs="-lX11 -lXext"
ecore_x_libs="-lecore_x";
],[
- AM_CONDITIONAL(BUILD_ECORE_X, false)
diff --git a/packages/efl/ecore/fix-tslib-configure.patch b/packages/efl/ecore/fix-tslib-configure.patch
new file mode 100644
index 0000000000..5a23f904dc
--- /dev/null
+++ b/packages/efl/ecore/fix-tslib-configure.patch
@@ -0,0 +1,12 @@
+diff -Nur ecore-0.9.9.015~/configure.in ecore-0.9.9.015/configure.in
+--- ecore-0.9.9.015~/configure.in 2005-09-27 17:22:38.000000000 -0700
++++ ecore-0.9.9.015/configure.in 2005-09-27 17:23:40.000000000 -0700
+@@ -103,7 +102,7 @@
+ tslib_libs=""
+ AC_CHECK_HEADER(tslib.h,
+ [
+- tslib_libs="-ltslib"
++ tslib_libs="-lts"
+ AC_DEFINE(HAVE_TSLIB, 1, [Build Ecore_X Module])
+ ],[
+ AC_MSG_RESULT("No tslib header found. No tslib support being built")