summaryrefslogtreecommitdiff
path: root/packages/efl/e_20060128.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-01-30 08:18:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-30 08:18:38 +0000
commit56435559deae7a21e210bd654706aef415904fc4 (patch)
tree9fdc9421531049c3ad132b2c71e2cd6d4fc3b237 /packages/efl/e_20060128.bb
parent9f00cacbccf02db56cb4e134a8dcecb6d13205d9 (diff)
efl, e17: update CVS versions again, fix cpp issues
- evas is left at 20060113 because it changed that day and breaks ecore - cpp and gcc paths are hard-coded to /usr/bin/ to fix some issues with OE's binaries in use with edje
Diffstat (limited to 'packages/efl/e_20060128.bb')
-rw-r--r--packages/efl/e_20060128.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/efl/e_20060128.bb b/packages/efl/e_20060128.bb
new file mode 100644
index 0000000000..495b647101
--- /dev/null
+++ b/packages/efl/e_20060128.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Enlightenment Window Mananger Library"
+DEPENDS = "virtual/evas virtual/ecore edje eet embryo"
+LICENSE = "MIT"
+PR = "r1"
+
+inherit efl
+
+SRC_URI = "cvs://anonymous@thinktux.net/root;module=e17/apps/e;date=${PV} \
+ file://fix-configure.patch;patch=1"
+S = "${WORKDIR}/e"
+
+PROFILE = "LORES_PDA"
+PROFILE_c7x0 = "HIRES_PDA"
+PROFILE_tosa = "HIRES_PDA"
+PROFILE_spitz = "HIRES_PDA"
+PROFILE_akita = "HIRES_PDA"
+
+EXTRA_OECONF = "--with-profile=${PROFILE} \
+ --with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR}"
+
+do_compile() {
+ oe_runmake -C src/lib
+}
+
+headers = "E_Lib.h ../bin/e*.h"
+
+do_install() {
+ oe_runmake -C src/lib install DESTDIR=${D}
+}