summaryrefslogtreecommitdiff
path: root/packages/efl/e_20050926.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-09-30 17:59:20 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-30 17:59:20 +0000
commit7e5e0be1af62584244662daa1989ffd8206c7298 (patch)
tree6eade7dca695f1668a509a7debde9aae887b9ff0 /packages/efl/e_20050926.bb
parent206647fb6ccf68137a2793c913053579f4553244 (diff)
e17, efl: major upgrade to newer versions
- Upgraded shapshot-based packages to newest released snapshots - Upgraded CVS-based packages to use a newer date - Moved e and e-wm to use snapshots as a default instead of CVS - Updated patches to work with newer versions - Added patches to fix problems introduced in newer versions - Added a patch to disable the splash for e-wm (causes a segfault) - entrance now uses ecore_config instead of edb - Added pulling of m4 directories for a few packages and running of aclocal due to autotools problems - elitaire currently does not compile, removed from e-image
Diffstat (limited to 'packages/efl/e_20050926.bb')
-rw-r--r--packages/efl/e_20050926.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/efl/e_20050926.bb b/packages/efl/e_20050926.bb
new file mode 100644
index 0000000000..eb2282c06b
--- /dev/null
+++ b/packages/efl/e_20050926.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Enlightenment Window Mananger Library"
+DEPENDS = "virtual/evas virtual/ecore edje eet embryo"
+LICENSE = "MIT"
+CVSDATE = "${PV}"
+PR = "r1"
+
+inherit efl
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/e \
+ file://fix-configure.patch;patch=1"
+S = "${WORKDIR}/e"
+
+PROFILE = "LORES_PDA"
+PROFILE_c7x0 = "HIRES_PDA"
+PROFILE_tosa = "HIRES_PDA"
+PROFILE_spitz = "HIRES_PDA"
+PROFILE_akita = "HIRES_PDA"
+
+EXTRA_OECONF = "--with-profile=${PROFILE} \
+ --with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR}"
+
+do_compile() {
+ oe_runmake -C src/lib
+}
+
+headers = "E_Lib.h ../bin/e*.h"
+
+do_install() {
+ oe_runmake -C src/lib install DESTDIR=${D}
+}