summaryrefslogtreecommitdiff
path: root/packages/efl/e_0.16.999.027.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-06-10 18:04:52 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-10 18:04:52 +0000
commit44d425781d950fc09c4d3df318e2c1b0bb31eab0 (patch)
tree419727d914619de68b5e2818000c6e1a1cef1524 /packages/efl/e_0.16.999.027.bb
parent1579edd1fd24a1afda9f8c5dbd1a4551a19424fb (diff)
efl, e17: update to newest versions
Diffstat (limited to 'packages/efl/e_0.16.999.027.bb')
-rw-r--r--packages/efl/e_0.16.999.027.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/efl/e_0.16.999.027.bb b/packages/efl/e_0.16.999.027.bb
new file mode 100644
index 0000000000..5078c71365
--- /dev/null
+++ b/packages/efl/e_0.16.999.027.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Enlightenment Window Mananger Library"
+DEPENDS = "virtual/evas virtual/ecore edje eet embryo"
+LICENSE = "MIT"
+PR = "r2"
+
+inherit efl
+
+SRC_URI = "${E_URI}/enlightenment-${PV}.tar.gz"
+S = "${WORKDIR}/enlightenment-${PV}"
+
+PROFILE = "LOWRES_PDA"
+PROFILE_c7x0 = "HIRES_PDA"
+PROFILE_tosa = "HIRES_PDA"
+PROFILE_spitz = "HIRES_PDA"
+PROFILE_akita = "HIRES_PDA"
+
+EXTRA_OECONF = "--with-profile=${PROFILE} \
+ --with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR}"
+
+do_compile() {
+ oe_runmake -C src/lib
+}
+
+headers = "E_Lib.h ../bin/e*.h"
+
+do_install() {
+ oe_runmake -C src/lib install DESTDIR=${D}
+}