summaryrefslogtreecommitdiff
path: root/packages/efl/e_0.16.999.025.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-04-06 22:39:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-06 22:39:32 +0000
commit6c97f56d28872da36cc0cc52631668985d8db22a (patch)
tree3957d53afc5c22540dedd5c61af13b28149a5b55 /packages/efl/e_0.16.999.025.bb
parent3bcd16909c945940017ded43f94652f1a7acf2f5 (diff)
parent254167bc41a3aae1c45a5f769ec16dee2dd37e2e (diff)
merge of 5945a66a6847c21d25595376695c23f3971f6f8a
and e544df2d6779a2a53f1c47a6d1e1961d875d17af
Diffstat (limited to 'packages/efl/e_0.16.999.025.bb')
-rw-r--r--packages/efl/e_0.16.999.025.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/efl/e_0.16.999.025.bb b/packages/efl/e_0.16.999.025.bb
new file mode 100644
index 0000000000..bd40c68b0e
--- /dev/null
+++ b/packages/efl/e_0.16.999.025.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Enlightenment Window Mananger Library"
+DEPENDS = "virtual/evas virtual/ecore edje eet embryo"
+LICENSE = "MIT"
+PR = "r2"
+
+inherit efl
+
+SRC_URI = "${E_URI}/enlightenment-${PV}.tar.gz"
+S = "${WORKDIR}/enlightenment-${PV}"
+
+PROFILE = "LORES_PDA"
+PROFILE_c7x0 = "HIRES_PDA"
+PROFILE_tosa = "HIRES_PDA"
+PROFILE_spitz = "HIRES_PDA"
+PROFILE_akita = "HIRES_PDA"
+
+EXTRA_OECONF = "--with-profile=${PROFILE} \
+ --with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR}"
+
+do_compile() {
+ oe_runmake -C src/lib
+}
+
+headers = "E_Lib.h ../bin/e*.h"
+
+do_install() {
+ oe_runmake -C src/lib install DESTDIR=${D}
+}