summaryrefslogtreecommitdiff
path: root/packages/efl++
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-19 15:04:51 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-19 15:04:51 +0000
commit70d68b647d317e0f110bb2a6ece9cf15e4f47fb4 (patch)
tree0b109bb14fc008777dbf2eb4ec520862783ab6ca /packages/efl++
parent1a4864b270fc2e87c9323305ba26a0d5c26bb1eb (diff)
add efl++, a C++ wrapper for the Enlightenment Foundation Libraries
Diffstat (limited to 'packages/efl++')
-rw-r--r--packages/efl++/.mtn2git_empty0
-rw-r--r--packages/efl++/efl++_0.0.2.bb48
2 files changed, 48 insertions, 0 deletions
diff --git a/packages/efl++/.mtn2git_empty b/packages/efl++/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/efl++/.mtn2git_empty
diff --git a/packages/efl++/efl++_0.0.2.bb b/packages/efl++/efl++_0.0.2.bb
new file mode 100644
index 0000000000..5803f5db7a
--- /dev/null
+++ b/packages/efl++/efl++_0.0.2.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "C++ Bindings for the Enlightenment Foundation Libraries"
+SECTION = "e/libs"
+LICENSE = "LGPL"
+AUTHOR = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+MAINTAINER = "${AUTHOR}"
+HOMEPAGE = "http://www.Vanille.de/projects/efl++.html"
+DEPENDS = "virtual/evas virtual/ecore edje"
+
+SRC_URI = "http://www.Vanille.de/temp/efl++_${PV}.tar.bz2"
+S = "${WORKDIR}/efl++-${PV}"
+
+inherit qmake
+
+PARALLEL_MAKE = ""
+QMAKE_PROFILES = "efl++.pro"
+EXTRA_QMAKEVARS_POST = "INCLUDEPATH+=${S}/src/evas INCLUDEPATH+=${S}/src/ecore INCLUDEPATH+=${S}/src/edje \
+ LIBS+=-L${S} DESTDIR=${S}"
+export OE_QMAKE_LINK="${CXX}"
+export EDIR="${S}"
+
+do_configure_prepend() {
+ rm include.pro
+ cat <<EOF >include.pro
+include ( common.pro )
+DEFINES += DATADIR=\"${datadir}/efl++/\"
+DEFINES += EFL_HAVE_X11
+EOF
+}
+
+do_stage() {
+ for i in src/evas/*.h src/ecore/*.h src/edje/*.h
+ do
+ install -m 0644 $i ${STAGING_INCDIR}
+ done
+ oe_libinstall -so -C ${S} libefl++ ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_libinstall -so -C ${S} libefl++ ${D}${libdir}
+ install -d ${D}${bindir}
+ install edje-simple ${D}${bindir}
+ install -d ${D}${datadir}/efl++
+ cp -a data/* ${D}${datadir}/efl++
+}
+
+PACKAGES =+ "efl++-examples"
+FILES_${PN} = "${libdir}"
+FILES_efl++-examples = "${bindir} ${datadir}"