summaryrefslogtreecommitdiff
path: root/packages/eet
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-08 21:54:08 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-08 21:54:08 +0000
commit7bd9307812da15188cfc5fc7a3b23f3a534c2caf (patch)
treefd5cc0d80f3c582af3968c43026ae90e657329fc /packages/eet
parent2807a92f94e9dcdecc51699ca95506a6e3737dc0 (diff)
e-libs: yank do_install() in all -native packages or else our precously crafted foo-config will get
overridden with what becomes foo-config-native... grrrr!
Diffstat (limited to 'packages/eet')
-rw-r--r--packages/eet/eet-native_0.9.10.013.bb17
-rw-r--r--packages/eet/eet_0.9.10.013.bb9
2 files changed, 9 insertions, 17 deletions
diff --git a/packages/eet/eet-native_0.9.10.013.bb b/packages/eet/eet-native_0.9.10.013.bb
index b08b724312..81f0a349fa 100644
--- a/packages/eet/eet-native_0.9.10.013.bb
+++ b/packages/eet/eet-native_0.9.10.013.bb
@@ -1,10 +1,3 @@
-DESCRIPTION = "EET is a tiny library designed to write an \
-arbitary set of chunks of data to a file and optionally compress \
-each chunk (very much like a zip file) and allow fast \
-random-access reading of the file later on."
-HOMEPAGE = "http://www.enlightenment.org"
-MAINTAINER = "Carsten Haitzler (Rasterman) <raster@rasterman.com>"
-SECTION = "e/libs"
PRIORITY = "optional"
include eet_${PV}.bb
inherit native
@@ -12,7 +5,11 @@ DEPENDS = "zlib-native jpeg-native"
LICENSE = "BSD"
do_stage () {
- install -m 0755 src/bin/.libs/eet ${STAGING_BINDIR}
- oe_libinstall -C src/lib libeet ${STAGING_LIBDIR}/
- install -m 0644 ${S}/src/lib/Eet.h ${STAGING_INCDIR}/
+ install -m 0755 src/bin/.libs/eet ${STAGING_BINDIR}
+ oe_libinstall -C src/lib libeet ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/src/lib/Eet.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ :
}
diff --git a/packages/eet/eet_0.9.10.013.bb b/packages/eet/eet_0.9.10.013.bb
index 2d62a6e9da..c2a7296706 100644
--- a/packages/eet/eet_0.9.10.013.bb
+++ b/packages/eet/eet_0.9.10.013.bb
@@ -9,19 +9,14 @@ DEPENDS = "zlib jpeg"
PR = "r0"
LICENSE = "BSD"
-do_prepsources () {
- make clean distclean || true
-}
-addtask prepsources after do_fetch before do_unpack
-
SRC_URI = "http://enlightenment.freedesktop.org/files/eet-${PV}.tar.gz"
S = "${WORKDIR}/eet-${PV}"
inherit autotools pkgconfig binconfig
do_stage () {
- oe_libinstall -C src/lib libeet ${STAGING_LIBDIR}/
- install -m 0644 ${S}/src/lib/Eet.h ${STAGING_INCDIR}/
+ oe_libinstall -C src/lib libeet ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/src/lib/Eet.h ${STAGING_INCDIR}/
}
FILES_${PN} = "${libdir}/libeet*.so*"