summaryrefslogtreecommitdiff
path: root/packages/ecj
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2007-07-24 20:32:51 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2007-07-24 20:32:51 +0000
commit7a8044caa66ef4afafecd61dc8fedc8972c7daa9 (patch)
treef589d94940444d36aede5cf267e52ae3b8e0a6a1 /packages/ecj
parentd0cec254188499c297c3b0fb12699b9be307b18c (diff)
-updating ecj to 3.3
-its the first step to intgrate cacao-cldc in oe
Diffstat (limited to 'packages/ecj')
-rw-r--r--packages/ecj/ecj-native_3.3.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/ecj/ecj-native_3.3.bb b/packages/ecj/ecj-native_3.3.bb
new file mode 100644
index 0000000000..ff2eb5f49e
--- /dev/null
+++ b/packages/ecj/ecj-native_3.3.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "JDT Core Batch Compiler"
+HOMEPAGE = "http://www.eclipse.org/"
+PRIORITY = "optional"
+SECTION = "devel"
+LICENSE = "EPL"
+PR = "r0"
+
+inherit native
+
+SRC_URI = "http://mirrors.ibiblio.org/pub/mirrors/eclipse/eclipse/downloads/drops/R-3.3-200706251500/ecj.jar \
+ file://ecj.sh"
+
+do_stage() {
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 755 ${S}/../ecj.jar ${STAGING_BINDIR_NATIVE}
+ install -m 755 ${S}/../ecj.sh ${STAGING_BINDIR_NATIVE}/ecj
+}