summaryrefslogtreecommitdiff
path: root/packages/ecj/ecj-bootstrap-native_3.4.bb
diff options
context:
space:
mode:
authorThomas Kunze <thommycheck@gmx.de>2008-07-27 15:12:12 +0000
committerThomas Kunze <thommycheck@gmx.de>2008-07-27 15:12:12 +0000
commit6860061f276f03cb005a43816e8ac69908285426 (patch)
tree09ee67ac944e41fbd11dfe8004757bf6104f6e03 /packages/ecj/ecj-bootstrap-native_3.4.bb
parentbe5fab607dec7bf7f9c69208cdc2ff98ef354357 (diff)
parent6271375d8dedfae87376847c2942f2d9fda43e4f (diff)
merge of '35d00516005b1f33ef42cecb0350a20a51723706'
and 'c167fd3cbb5184fbfe56dff8fbb57e988ce58f51'
Diffstat (limited to 'packages/ecj/ecj-bootstrap-native_3.4.bb')
-rw-r--r--packages/ecj/ecj-bootstrap-native_3.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/ecj/ecj-bootstrap-native_3.4.bb b/packages/ecj/ecj-bootstrap-native_3.4.bb
new file mode 100644
index 0000000000..bd4347457c
--- /dev/null
+++ b/packages/ecj/ecj-bootstrap-native_3.4.bb
@@ -0,0 +1,38 @@
+# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
+# and no less features.
+#
+# Since the VM running the compiler has no effect on the produced bytecode this recipe
+# uses the jar created by ecj-initial and creates a start script that runs it with a different
+# VM.
+
+DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
+HOMEPAGE = "http://www.eclipse.org/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "EPL"
+
+DEPENDS = "ecj-initial virtual/java-native"
+
+PROVIDES = "virtual/javac-native"
+
+SRC_URI = "file://ecj.in"
+
+S = "${WORKDIR}"
+
+JAR = "ecj-bootstrap-${PV}.jar"
+
+inherit native
+
+do_compile() {
+ # Create the start script
+ echo "#!/bin/sh" > ecj-bootstrap
+ echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap
+ echo "RUNTIME=java" >> ecj-bootstrap
+ cat ecj.in >> ecj-bootstrap
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
+}