summaryrefslogtreecommitdiff
path: root/packages/ecj/ecj-bootstrap-native_3.3.2.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-27 10:32:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-27 10:32:12 +0000
commitccf82499ebfe39b56600044ec78273fd13ba23b0 (patch)
tree82eb3854c2d16f38651ab3b09b161e4be3ac1764 /packages/ecj/ecj-bootstrap-native_3.3.2.bb
parent3b770f96f6991d6d43a83f035e6cf98a2d040d92 (diff)
parent18afb09aa6c08b22f6455dd5f9e2a6a16fe38312 (diff)
merge of '2700039073a3760641797b52ac5897f2eee3d92a'
and 'ddb3262e0fe9acfe7d20567e33ef27bcfe0d0801'
Diffstat (limited to 'packages/ecj/ecj-bootstrap-native_3.3.2.bb')
-rw-r--r--packages/ecj/ecj-bootstrap-native_3.3.2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/ecj/ecj-bootstrap-native_3.3.2.bb b/packages/ecj/ecj-bootstrap-native_3.3.2.bb
new file mode 100644
index 0000000000..bd4347457c
--- /dev/null
+++ b/packages/ecj/ecj-bootstrap-native_3.3.2.bb
@@ -0,0 +1,38 @@
+# ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
+# and no less features.
+#
+# Since the VM running the compiler has no effect on the produced bytecode this recipe
+# uses the jar created by ecj-initial and creates a start script that runs it with a different
+# VM.
+
+DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
+HOMEPAGE = "http://www.eclipse.org/"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "EPL"
+
+DEPENDS = "ecj-initial virtual/java-native"
+
+PROVIDES = "virtual/javac-native"
+
+SRC_URI = "file://ecj.in"
+
+S = "${WORKDIR}"
+
+JAR = "ecj-bootstrap-${PV}.jar"
+
+inherit native
+
+do_compile() {
+ # Create the start script
+ echo "#!/bin/sh" > ecj-bootstrap
+ echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap
+ echo "RUNTIME=java" >> ecj-bootstrap
+ cat ecj.in >> ecj-bootstrap
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
+ install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
+}