summaryrefslogtreecommitdiff
path: root/packages/eb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-02-07 22:17:17 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-02-07 22:17:17 +0000
commit57c2f23e84f3916a179a1135578fd6a24d0c8587 (patch)
treee83498ae0c312155974e597f26b7ee6b266238be /packages/eb
parent0313defa39c55357c11368006acc957ee9ea5cb9 (diff)
eb: update to version 4.3.2
* fixes unfetchable source * improve packaging granularity (add utils package and make sure doc stuff is actually in -doc) * use autotools_stage_all instead of custom do_stage routine (comment 11 from bug 1383)
Diffstat (limited to 'packages/eb')
-rw-r--r--packages/eb/eb_4.3.2.bb (renamed from packages/eb/eb_4.3.bb)12
1 files changed, 8 insertions, 4 deletions
diff --git a/packages/eb/eb_4.3.bb b/packages/eb/eb_4.3.2.bb
index 29bd53dfea..5ba61c7cdb 100644
--- a/packages/eb/eb_4.3.bb
+++ b/packages/eb/eb_4.3.2.bb
@@ -2,13 +2,17 @@ DESCRIPTION = "Electronic book library"
HOMEPAGE = "http://www.sra.co.jp/people/m-kasahr/eb"
SECTION = "libs"
LICENSE = "GPL"
+#DEPENDS = "zlib"
SRC_URI = "ftp://ftp.sra.co.jp/pub/misc/eb/eb-${PV}.tar.bz2"
-inherit autotools pkgconfig
+inherit autotools
+
+EXTRA_OECONF += " --with-pkgdocdir=${docdir}/eb"
do_stage () {
- install -d ${STAGING_INCDIR}/eb/
- install -m 0644 eb/*.h ${STAGING_INCDIR}/eb/
- install eb/.libs/libeb.so ${STAGING_LIBDIR}
+ autotools_stage_all
}
+
+PACKAGES =+ "eb-utils"
+FILES_eb-utils = "/usr/bin/*"