summaryrefslogtreecommitdiff
path: root/packages/e17
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-02-06 00:46:35 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-06 00:46:35 +0000
commit9b188ea2600bce6ed35559b21677bd8b7223f5a8 (patch)
tree40e9328ce853279c0eae8ecc851d514ef01c26d1 /packages/e17
parent76107d774ec7a96b7788d2f2b98b5621a04cfe71 (diff)
parent1be31761f3449cd4f92508fd2c2c41968039c918 (diff)
merge of 1133a2f6d7624f04cdda9771f28e1502680e7213
and 59438d13db19ded8e22646fb8cddf849804f3a90
Diffstat (limited to 'packages/e17')
-rw-r--r--packages/e17/e-wm_0.16.999.023.bb (renamed from packages/e17/e-wm_0.16.999.022.bb)2
-rw-r--r--packages/e17/entrance/fix-auth-mode.patch11
-rw-r--r--packages/e17/entrance/use-bash.patch64
-rw-r--r--packages/e17/entrance_0.9.0.005.bb38
-rw-r--r--packages/e17/entrance_20060128.bb5
5 files changed, 106 insertions, 14 deletions
diff --git a/packages/e17/e-wm_0.16.999.022.bb b/packages/e17/e-wm_0.16.999.023.bb
index 60d5fe6571..ef0162a174 100644
--- a/packages/e17/e-wm_0.16.999.022.bb
+++ b/packages/e17/e-wm_0.16.999.023.bb
@@ -8,9 +8,9 @@ PR = "r3"
SRC_URI = "http://enlightenment.freedesktop.org/files/enlightenment-${PV}.tar.gz \
file://fix-configure.patch;patch=1 \
file://remove-large-fonts.patch;patch=1 \
- file://disable-splash.patch;patch=1 \
file://Xsession.d/98enlightenment \
cvs://anonymous@thinktux.net/root;module=e17/apps/e/data/themes;date=20050926"
+# file://disable-splash.patch;patch=1 \
# http://cvs.sourceforge.net/viewcvs.py/*checkout*/enlightenment/e17/apps/e/data/themes/default_entry.edc?rev=1.1 \
# http://cvs.sourceforge.net/viewcvs.py/*checkout*/enlightenment/e17/apps/e/data/themes/images/focus.png?rev=1.1 \
# http://cvs.sourceforge.net/viewcvs.py/*checkout*/enlightenment/e17/apps/e/data/themes/images/entry.png?rev=1.1 \
diff --git a/packages/e17/entrance/fix-auth-mode.patch b/packages/e17/entrance/fix-auth-mode.patch
new file mode 100644
index 0000000000..1ec520f768
--- /dev/null
+++ b/packages/e17/entrance/fix-auth-mode.patch
@@ -0,0 +1,11 @@
+--- entrance/data/config/build_config.sh.in~ 2006-01-30 07:01:47.000000000 -0800
++++ entrance/data/config/build_config.sh.in 2006-02-01 22:22:04.000000000 -0800
+@@ -3,7 +3,7 @@
+ rm -f $DB
+
+ # set auth to 1 for pam, 2 for shadow
+-ecore_config -c $DB -k /entrance/auth -i @auth_mode@
++ecore_config -c $DB -k /entrance/auth -i 0
+
+ # uncomment the below to enable experimental OpenGL hardware acceleration
+ #ecore_config -c $DB -k /entrance/engine -i 1
diff --git a/packages/e17/entrance/use-bash.patch b/packages/e17/entrance/use-bash.patch
index 5c6d1992c8..58ef8f556f 100644
--- a/packages/e17/entrance/use-bash.patch
+++ b/packages/e17/entrance/use-bash.patch
@@ -1,12 +1,54 @@
diff -Nur entrance~/src/client/entrance_session.c entrance/src/client/entrance_session.c
---- entrance~/src/client/entrance_session.c 2005-09-29 15:03:26.000000000 -0700
-+++ entrance/src/client/entrance_session.c 2005-09-29 15:04:11.000000000 -0700
-@@ -470,7 +470,7 @@
- snprintf(buf, sizeof(buf), "%s/entrance_login %i", PACKAGE_BIN_DIR,
- (int) pid);
- }
-- shell = strdup("/bin/sh");
-+ shell = strdup("/bin/bash");
- /* this bypasses a race condition where entrance loses its x
- connection before the wm gets it and x goes and resets itself */
- sleep(10);
+--- entrance~/src/client/entrance_session.c 2006-02-02 19:51:40.000000000 -0800
++++ entrance/src/client/entrance_session.c 2006-02-02 19:59:24.000000000 -0800
+@@ -495,7 +495,7 @@
+ entrance_session_free(e);
+ /* replace this process with a clean small one that just waits for its */
+ /* child to exit.. passed on the cmd-line */
+- execl("/bin/sh", "/bin/sh", "-l", "-c", buf, NULL);
++ execl("/bin/bash", "/bin/bash", "-l", "-c", buf, NULL);
+ }
+
+
+diff -Nur entrance~/src/client/main.c entrance/src/client/main.c
+--- entrance~/src/client/main.c 2006-02-02 19:51:40.000000000 -0800
++++ entrance/src/client/main.c 2006-02-02 19:57:24.000000000 -0800
+@@ -392,7 +392,7 @@
+ {
+ case 0:
+ if (execl
+- ("/bin/sh", "/bin/sh", "-c", "/sbin/shutdown -r now", NULL))
++ ("/bin/bash", "/bin/bash", "-c", "/sbin/shutdown -r now", NULL))
+ {
+ syslog(LOG_CRIT,
+ "Reboot failed: Unable to execute /sbin/shutdown");
+@@ -434,7 +434,7 @@
+ {
+ case 0:
+ if (execl
+- ("/bin/sh", "/bin/sh", "-c", "/sbin/shutdown -h now", NULL))
++ ("/bin/bash", "/bin/bash", "-c", "/sbin/shutdown -h now", NULL))
+ {
+ syslog(LOG_CRIT,
+ "Shutdown failed: Unable to execute /sbin/shutdown");
+diff -Nur entrance~/src/daemon/entrance_wrapper.in entrance/src/daemon/entrance_wrapper.in
+--- entrance~/src/daemon/entrance_wrapper.in 2006-02-02 19:51:40.000000000 -0800
++++ entrance/src/daemon/entrance_wrapper.in 2006-02-02 19:56:43.000000000 -0800
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+ # Wrapper script to set up login environment:
+ # Load up all the junk in /etc/profile first, and then
+ # pass control to entrance proper.
+diff -Nur entrance~/src/daemon/spawner.c entrance/src/daemon/spawner.c
+--- entrance~/src/daemon/spawner.c 2006-02-02 19:51:40.000000000 -0800
++++ entrance/src/daemon/spawner.c 2006-02-02 19:57:10.000000000 -0800
+@@ -162,7 +162,7 @@
+ sigaction(SIGUSR1, &_entrance_x_sa, NULL);
+ /* FIXME: need to parse command and NOT go thru /bin/sh!!!! */
+ /* why? some /bin/sh's wont pass on this SIGUSR1 thing... */
+- execl("/bin/sh", "/bin/sh", "-c", x_cmd, NULL);
++ execl("/bin/bash", "/bin/bash", "-c", x_cmd, NULL);
+ syslog(LOG_WARNING, "Could not execute X server.");
+ exit(1);
+ default:
diff --git a/packages/e17/entrance_0.9.0.005.bb b/packages/e17/entrance_0.9.0.005.bb
new file mode 100644
index 0000000000..b79e26d4a4
--- /dev/null
+++ b/packages/e17/entrance_0.9.0.005.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Entrance is the Enlightenment login manager"
+SECTION = "e/apps"
+LICENSE = "MIT"
+# can also use pam and crypt
+DEPENDS = "edb edb-native evas-x11 ecore-x11 edje esmart-x11 bash keylaunch detect-stylus xserver-common"
+RDEPENDS += "bash keylaunch detect-stylus xserver-common glibc-gconv-iso8859-1"
+HOMEPAGE = "http://www.enlightenment.org"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+PR = "r11"
+
+SRC_URI = "http://enlightenment.freedesktop.org/files/entrance-${PV}.tar.gz \
+ file://config-db.patch;patch=1 \
+ file://allow-missing-xsession.patch;patch=1 \
+ file://run-Xinit.patch;patch=1 \
+ file://set-display-env.patch;patch=1 \
+ file://fix-auth-mode.patch;patch=1 \
+ file://use-bash.patch;patch=1 \
+ file://Sessions"
+
+S = "${WORKDIR}/entrance-${PV}"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "entrance"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --with-xsession=/etc/X11/Xsession \
+ --with-auth-mode=0"
+
+FILES += "${datadir}"
+
+do_install_append() {
+ install -d ${D}/etc/X11/Xsession.d
+ install -d ${D}/etc/X11/Sessions
+
+ install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
+}
diff --git a/packages/e17/entrance_20060128.bb b/packages/e17/entrance_20060128.bb
index 3d4eacf73d..b234664fe6 100644
--- a/packages/e17/entrance_20060128.bb
+++ b/packages/e17/entrance_20060128.bb
@@ -6,14 +6,15 @@ DEPENDS = "edb edb-native evas-x11 ecore-x11 edje esmart-x11 bash keylaunch dete
RDEPENDS += "bash keylaunch detect-stylus xserver-common glibc-gconv-iso8859-1"
HOMEPAGE = "http://www.enlightenment.org"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
-PR = "r9"
+PR = "r11"
SRC_URI = "cvs://anonymous@thinktux.net/root;module=e17/apps/entrance;date=${PV} \
file://config-db.patch;patch=1 \
file://allow-missing-xsession.patch;patch=1 \
file://run-Xinit.patch;patch=1 \
- file://use-bash.patch;patch=1 \
file://set-display-env.patch;patch=1 \
+ file://fix-auth-mode.patch;patch=1 \
+ file://use-bash.patch;patch=1 \
file://Sessions"
S = "${WORKDIR}/entrance"