summaryrefslogtreecommitdiff
path: root/packages/e17
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-08-13 00:50:47 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-13 00:50:47 +0000
commitcef4e511868d109e5775ba2d21f7ef988b86f9a4 (patch)
treef578161abff8d88f9b837925054875b176950f7f /packages/e17
parent571a4fc239ca4358c47664c26683370354ce4f6f (diff)
Fix dependencies for all EFL and E17 packages
Fix problems with edje/embryo (stage .inc files) Add a patch for e-wm which will automatically scroll menus onto the screen when the cursor is within 5px of the edge of the screen Enable edb frontends for GTK and ncurses
Diffstat (limited to 'packages/e17')
-rw-r--r--packages/e17/e-utils_20050810.bb2
-rw-r--r--packages/e17/e-wm/fudge_screen_edges_for_menu.patch29
-rw-r--r--packages/e17/e-wm_20050810.bb5
-rw-r--r--packages/e17/entice_20050810.bb3
-rw-r--r--packages/e17/entrance_20050810.bb5
5 files changed, 38 insertions, 6 deletions
diff --git a/packages/e17/e-utils_20050810.bb b/packages/e17/e-utils_20050810.bb
index 273c7622e6..00fa240264 100644
--- a/packages/e17/e-utils_20050810.bb
+++ b/packages/e17/e-utils_20050810.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Enlightenment Window Manager Utilities"
-DEPENDS = "freetype eet evas-x11 ecore-x11 edje engrave esmart epsilon ewl imlib2-x11 e17"
+DEPENDS = "virtual/ecore virtual/evas esmart edje eet ewl engrave virtual/imlib2 e epsilon"
LICENSE = "MIT"
SECTION = "e/apps"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
diff --git a/packages/e17/e-wm/fudge_screen_edges_for_menu.patch b/packages/e17/e-wm/fudge_screen_edges_for_menu.patch
new file mode 100644
index 0000000000..c203fd4ae0
--- /dev/null
+++ b/packages/e17/e-wm/fudge_screen_edges_for_menu.patch
@@ -0,0 +1,29 @@
+--- e/src/bin/e_menu.c.~1.38.~ 2005-07-25 02:55:44.000000000 -0700
++++ e/src/bin/e_menu.c 2005-08-11 15:36:23.000000000 -0700
+@@ -1968,22 +1968,22 @@
+ E_Menu *m;
+
+ m = l->data;
+- if (m->cur.x < m->zone->x)
++ if (m->cur.x < m->zone->x + 5)
+ {
+ i = m->zone->x - m->cur.x;
+ if (i > outl) outl = i;
+ }
+- if (m->cur.y < m->zone->y)
++ if (m->cur.y < m->zone->y + 5)
+ {
+ i = m->zone->y - m->cur.y;
+ if (i > outt) outt = i;
+ }
+- if ((m->cur.x + m->cur.w) > (m->zone->w))
++ if ((m->cur.x + m->cur.w) > (m->zone->w - 5))
+ {
+ i = m->cur.x + m->cur.w - (m->zone->x + m->zone->w);
+ if (i > outr) outr = i;
+ }
+- if ((m->cur.y + m->cur.h) > (m->zone->h))
++ if ((m->cur.y + m->cur.h) > (m->zone->h - 5))
+ {
+ i = m->cur.y + m->cur.h - (m->zone->y + m->zone->h);
+ if (i > outb) outb = i;
diff --git a/packages/e17/e-wm_20050810.bb b/packages/e17/e-wm_20050810.bb
index 2f6b3c3443..b5b137eb16 100644
--- a/packages/e17/e-wm_20050810.bb
+++ b/packages/e17/e-wm_20050810.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "E17 - the Enlightenment Window Mananger"
-DEPENDS = "freetype eet evas-x11 ecore-x11 embryo imlib2-x11 edje-native e"
+DEPENDS = "virtual/evas virtual/ecore edje eet embryo e"
LICENSE = "MIT"
SECTION = "e/apps"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
@@ -7,7 +7,8 @@ CVSDATE = "${PV}"
PR = "r0"
SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/e \
- file://fix-configure.patch;patch=1"
+ file://fix-configure.patch;patch=1 \
+ file://fudge_screen_edges_for_menu.patch;patch=1"
S = "${WORKDIR}/e"
inherit autotools
diff --git a/packages/e17/entice_20050810.bb b/packages/e17/entice_20050810.bb
index fc4d8c51af..ac454e7189 100644
--- a/packages/e17/entice_20050810.bb
+++ b/packages/e17/entice_20050810.bb
@@ -1,6 +1,7 @@
DESCRIPTION = "Entice is a picture viewer"
SECTION = "e/apps"
-DEPENDS = "freetype eet virtual/evas virtual/ecore embryo virtual/imlib2 edje-native"
+# can also depend on GIMP for editing
+DEPENDS = "virtual/evas edb virtual/ecore edje"
LICENSE = "MIT"
HOMEPAGE = "http://www.enlightenment.org"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
diff --git a/packages/e17/entrance_20050810.bb b/packages/e17/entrance_20050810.bb
index afc0e82825..471b7d31bb 100644
--- a/packages/e17/entrance_20050810.bb
+++ b/packages/e17/entrance_20050810.bb
@@ -1,7 +1,8 @@
-DESCRIPTION = "Entrace is the Enlightenment login manager for X11"
+DESCRIPTION = "Entrace is the Enlightenment login manager"
SECTION = "e/apps"
LICENSE = "MIT"
-DEPENDS = "ecore-x11 edje-native embryo-native esmart"
+# can also use pam and crypt
+DEPENDS = "edb virtual/evas virtual/ecore edje esmart"
HOMEPAGE = "http://www.enlightenment.org"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
CVSDATE = "${PV}"