summaryrefslogtreecommitdiff
path: root/packages/e17
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-08-17 18:22:44 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-17 18:22:44 +0000
commitb2f3f8cc7f674402dae1e325a44d44615295fd0d (patch)
treeb26814fa84abd7bc7a1e9fedec2c7e947b2a0dd3 /packages/e17
parenta098af2fcdd0a2cdefd7049cdc12a5fda8e46638 (diff)
parentc355755e38003a906085114be463792fd9de4ff8 (diff)
merge of 885d90470dc44f85332ae3b62f38a1f1cf91b4c5
and c9530ced58773f4fa9498d173533e73615774c22
Diffstat (limited to 'packages/e17')
-rw-r--r--packages/e17/e-wm/add-menu-autoscroll-options.patch207
-rw-r--r--packages/e17/e-wm/fudge_screen_edges_for_menu.patch29
-rw-r--r--packages/e17/e-wm_20050810.bb4
-rw-r--r--packages/e17/e17genmenu_2.0.2.bb22
-rw-r--r--packages/e17/eclair_20050810.bb4
-rw-r--r--packages/e17/engage/.mtn2git_empty0
-rw-r--r--packages/e17/engage/no-local-includes.patch17
-rw-r--r--packages/e17/engage_20050810.bb9
-rw-r--r--packages/e17/entice_20050810.bb4
-rw-r--r--packages/e17/entrance/Sessions/.mtn2git_empty0
-rw-r--r--packages/e17/entrance/Sessions/Enlightenment4
-rw-r--r--packages/e17/entrance/Sessions/Failsafe3
-rw-r--r--packages/e17/entrance/Xinit.d/.mtn2git_empty0
-rw-r--r--packages/e17/entrance/Xinit.d/50-calibrate7
-rw-r--r--packages/e17/entrance/Xinit.d/99-Entrance4
-rw-r--r--packages/e17/entrance/config-db.patch57
-rw-r--r--packages/e17/entrance/longer-sleep.patch11
-rw-r--r--packages/e17/entrance/run-Xinit.patch17
-rw-r--r--packages/e17/entrance/use-bash.patch11
-rw-r--r--packages/e17/entrance_20050810.bb26
-rw-r--r--packages/e17/examine_20050810.bb2
21 files changed, 354 insertions, 84 deletions
diff --git a/packages/e17/e-wm/add-menu-autoscroll-options.patch b/packages/e17/e-wm/add-menu-autoscroll-options.patch
new file mode 100644
index 0000000000..79bcad8e44
--- /dev/null
+++ b/packages/e17/e-wm/add-menu-autoscroll-options.patch
@@ -0,0 +1,207 @@
+diff -Nur e~/src/bin/e_config.c e/src/bin/e_config.c
+--- e~/src/bin/e_config.c 2005-08-05 21:12:17.000000000 -0700
++++ e/src/bin/e_config.c 2005-08-16 13:55:06.000000000 -0700
+@@ -298,6 +298,8 @@
+ E_CONFIG_VAL(D, T, resize_info_follows, INT); /**/
+ E_CONFIG_VAL(D, T, focus_last_focused_per_desktop, INT); /**/
+ E_CONFIG_VAL(D, T, focus_revert_on_hide_or_close, INT); /**/
++ E_CONFIG_VAL(D, T, menu_autoscroll_margin, INT); /**/
++ E_CONFIG_VAL(D, T, menu_autoscroll_cursor_margin, INT); /**/
+
+ e_config = e_config_domain_load("e", _e_config_edd);
+ if (e_config)
+@@ -403,6 +405,8 @@
+ e_config->resize_info_follows = 1;
+ e_config->focus_last_focused_per_desktop = 1;
+ e_config->focus_revert_on_hide_or_close = 1;
++ e_config->menu_autoscroll_margin = 10;
++ e_config->menu_autoscroll_cursor_margin = 15;
+
+ {
+ E_Config_Module *em;
+@@ -959,6 +963,8 @@
+ E_CONFIG_LIMIT(e_config->resize_info_follows, 0, 1);
+ E_CONFIG_LIMIT(e_config->focus_last_focused_per_desktop, 0, 1);
+ E_CONFIG_LIMIT(e_config->focus_revert_on_hide_or_close, 0, 1);
++ E_CONFIG_LIMIT(e_config->menu_autoscroll_margin, 0, 50);
++ E_CONFIG_LIMIT(e_config->menu_autoscroll_cursor_margin, 0, 50);
+
+ /* apply lang config - exception because config is loaded after intl setup */
+
+diff -Nur e~/src/bin/e_config.h e/src/bin/e_config.h
+--- e~/src/bin/e_config.h 2005-08-05 21:12:18.000000000 -0700
++++ e/src/bin/e_config.h 2005-08-16 13:55:06.000000000 -0700
+@@ -142,6 +142,8 @@
+ int resize_info_follows;
+ int focus_last_focused_per_desktop;
+ int focus_revert_on_hide_or_close;
++ int menu_autoscroll_margin;
++ int menu_autoscroll_cursor_margin;
+ };
+
+ struct _E_Config_Module
+diff -Nur e~/src/bin/e_ipc_handlers.h e/src/bin/e_ipc_handlers.h
+--- e~/src/bin/e_ipc_handlers.h 2005-08-09 21:52:07.000000000 -0700
++++ e/src/bin/e_ipc_handlers.h 2005-08-16 14:01:38.000000000 -0700
+@@ -4592,3 +4592,84 @@
+ #if 0
+ }
+ #endif
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_MARGIN_SET
++#if (TYPE == E_REMOTE_OPTIONS)
++ OP("-menu-autoscroll-margin-set", 1, "Set the distance from the edge of the screen the menu will autoscroll to", 0, HDL)
++#elif (TYPE == E_REMOTE_OUT)
++ REQ_INT(atoi(params[0]), HDL);
++#elif (TYPE == E_WM_IN)
++ START_INT(value, HDL);
++ e_config->menu_autoscroll_margin = value;
++ E_CONFIG_LIMIT(e_config->menu_autoscroll_margin, 0, 50);
++ SAVE;
++ END_INT;
++#elif (TYPE == E_REMOTE_IN)
++#endif
++#undef HDL
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_MARGIN_GET
++#if (TYPE == E_REMOTE_OPTIONS)
++ OP("-menu-autoscroll-margin-get", 0, "Get the distance from the edge of the screen the menu will autoscroll to", 1, HDL)
++#elif (TYPE == E_REMOTE_OUT)
++ REQ_NULL(HDL)
++#elif (TYPE == E_WM_IN)
++ SEND_INT(e_config->menu_autoscroll_margin, E_IPC_OP_MENU_AUTOSCROLL_MARGIN_GET_REPLY, HDL);
++#elif (TYPE == E_REMOTE_IN)
++#endif
++#undef HDL
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_MARGIN_GET_REPLY
++#if (TYPE == E_REMOTE_OPTIONS)
++#elif (TYPE == E_REMOTE_OUT)
++#elif (TYPE == E_WM_IN)
++#elif (TYPE == E_REMOTE_IN)
++ START_INT(val, HDL)
++ printf("REPLY: %i\n", val);
++ END_INT;
++#endif
++#undef HDL
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_SET
++#if (TYPE == E_REMOTE_OPTIONS)
++ OP("-menu-autoscroll-cursor-margin-set", 1, "Set the distance from the edge of the screen the cursor needs to be to start menu autoscrolling", 0, HDL)
++#elif (TYPE == E_REMOTE_OUT)
++ REQ_INT(atoi(params[0]), HDL);
++#elif (TYPE == E_WM_IN)
++ START_INT(value, HDL);
++ e_config->menu_autoscroll_cursor_margin = value;
++ E_CONFIG_LIMIT(e_config->menu_autoscroll_cursor_margin, 0, 50);
++ // e_zone_update_flip_all();
++ SAVE;
++ END_INT;
++#elif (TYPE == E_REMOTE_IN)
++#endif
++#undef HDL
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_GET
++#if (TYPE == E_REMOTE_OPTIONS)
++ OP("-menu-autoscroll-cursor-margin-get", 0, "Get the distance from the edge of the screen the cursor needs to be to start menu autoscrolling", 1, HDL)
++#elif (TYPE == E_REMOTE_OUT)
++ REQ_NULL(HDL)
++#elif (TYPE == E_WM_IN)
++ SEND_INT(e_config->menu_autoscroll_cursor_margin, E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_GET_REPLY, HDL);
++#elif (TYPE == E_REMOTE_IN)
++#endif
++#undef HDL
++
++/****************************************************************************/
++#define HDL E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_GET_REPLY
++#if (TYPE == E_REMOTE_OPTIONS)
++#elif (TYPE == E_REMOTE_OUT)
++#elif (TYPE == E_WM_IN)
++#elif (TYPE == E_REMOTE_IN)
++ START_INT(val, HDL)
++ printf("REPLY: %i\n", val);
++ END_INT;
++#endif
++#undef HDL
+diff -Nur e~/src/bin/e_ipc_handlers_list.h e/src/bin/e_ipc_handlers_list.h
+--- e~/src/bin/e_ipc_handlers_list.h 2005-08-05 21:00:03.000000000 -0700
++++ e/src/bin/e_ipc_handlers_list.h 2005-08-16 13:55:06.000000000 -0700
+@@ -222,3 +222,9 @@
+ #define E_IPC_OP_DESKTOP_NAME_DEL 222
+ #define E_IPC_OP_DESKTOP_NAME_LIST 223
+ #define E_IPC_OP_DESKTOP_NAME_LIST_REPLY 224
++#define E_IPC_OP_MENU_AUTOSCROLL_MARGIN_SET 225
++#define E_IPC_OP_MENU_AUTOSCROLL_MARGIN_GET 226
++#define E_IPC_OP_MENU_AUTOSCROLL_MARGIN_GET_REPLY 227
++#define E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_SET 228
++#define E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_GET 229
++#define E_IPC_OP_MENU_AUTOSCROLL_CURSOR_MARGIN_GET_REPLY 230
+diff -Nur e~/src/bin/e_menu.c e/src/bin/e_menu.c
+--- e~/src/bin/e_menu.c 2005-07-25 02:55:44.000000000 -0700
++++ e/src/bin/e_menu.c 2005-08-16 13:55:06.000000000 -0700
+@@ -1968,24 +1968,24 @@
+ E_Menu *m;
+
+ m = l->data;
+- if (m->cur.x < m->zone->x)
++ if (m->cur.x < m->zone->x + e_config->menu_autoscroll_margin)
+ {
+- i = m->zone->x - m->cur.x;
++ i = m->zone->x - m->cur.x + e_config->menu_autoscroll_margin;
+ if (i > outl) outl = i;
+ }
+- if (m->cur.y < m->zone->y)
++ if (m->cur.y < m->zone->y + e_config->menu_autoscroll_margin)
+ {
+- i = m->zone->y - m->cur.y;
++ i = m->zone->y - m->cur.y + e_config->menu_autoscroll_margin;
+ if (i > outt) outt = i;
+ }
+- if ((m->cur.x + m->cur.w) > (m->zone->w))
++ if ((m->cur.x + m->cur.w) > (m->zone->w - e_config->menu_autoscroll_margin))
+ {
+- i = m->cur.x + m->cur.w - (m->zone->x + m->zone->w);
++ i = m->cur.x + m->cur.w - (m->zone->x + m->zone->w - e_config->menu_autoscroll_margin);
+ if (i > outr) outr = i;
+ }
+- if ((m->cur.y + m->cur.h) > (m->zone->h))
++ if ((m->cur.y + m->cur.h) > (m->zone->h - e_config->menu_autoscroll_margin))
+ {
+- i = m->cur.y + m->cur.h - (m->zone->y + m->zone->h);
++ i = m->cur.y + m->cur.h - (m->zone->y + m->zone->h - e_config->menu_autoscroll_margin);
+ if (i > outb) outb = i;
+ }
+ }
+@@ -2029,11 +2029,11 @@
+ int autoscroll_x = 0;
+ int autoscroll_y = 0;
+
+- if (_e_menu_x == 0)
++ if (_e_menu_x - e_config->menu_autoscroll_cursor_margin <= 0)
+ {
+ if (_e_menu_outside_bounds_get(-1, 0)) autoscroll_x = -1;
+ }
+- if (_e_menu_y == 0)
++ if (_e_menu_y - e_config->menu_autoscroll_cursor_margin <= 0)
+ {
+ if (_e_menu_outside_bounds_get(0, -1)) autoscroll_y = -1;
+ }
+@@ -2044,11 +2044,11 @@
+ E_Menu *m;
+
+ m = _e_active_menus->data;
+- if (_e_menu_x == (m->zone->w - 1))
++ if (_e_menu_x + e_config->menu_autoscroll_cursor_margin >= (m->zone->w - 1))
+ {
+ if (_e_menu_outside_bounds_get(1, 0)) autoscroll_x = 1;
+ }
+- if (_e_menu_y == (m->zone->h - 1))
++ if (_e_menu_y + e_config->menu_autoscroll_cursor_margin >= (m->zone->h - 1))
+ {
+ if (_e_menu_outside_bounds_get(0, 1)) autoscroll_y = 1;
+ }
diff --git a/packages/e17/e-wm/fudge_screen_edges_for_menu.patch b/packages/e17/e-wm/fudge_screen_edges_for_menu.patch
deleted file mode 100644
index c203fd4ae0..0000000000
--- a/packages/e17/e-wm/fudge_screen_edges_for_menu.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- e/src/bin/e_menu.c.~1.38.~ 2005-07-25 02:55:44.000000000 -0700
-+++ e/src/bin/e_menu.c 2005-08-11 15:36:23.000000000 -0700
-@@ -1968,22 +1968,22 @@
- E_Menu *m;
-
- m = l->data;
-- if (m->cur.x < m->zone->x)
-+ if (m->cur.x < m->zone->x + 5)
- {
- i = m->zone->x - m->cur.x;
- if (i > outl) outl = i;
- }
-- if (m->cur.y < m->zone->y)
-+ if (m->cur.y < m->zone->y + 5)
- {
- i = m->zone->y - m->cur.y;
- if (i > outt) outt = i;
- }
-- if ((m->cur.x + m->cur.w) > (m->zone->w))
-+ if ((m->cur.x + m->cur.w) > (m->zone->w - 5))
- {
- i = m->cur.x + m->cur.w - (m->zone->x + m->zone->w);
- if (i > outr) outr = i;
- }
-- if ((m->cur.y + m->cur.h) > (m->zone->h))
-+ if ((m->cur.y + m->cur.h) > (m->zone->h - 5))
- {
- i = m->cur.y + m->cur.h - (m->zone->y + m->zone->h);
- if (i > outb) outb = i;
diff --git a/packages/e17/e-wm_20050810.bb b/packages/e17/e-wm_20050810.bb
index 180f2f8c86..7929f1a807 100644
--- a/packages/e17/e-wm_20050810.bb
+++ b/packages/e17/e-wm_20050810.bb
@@ -4,11 +4,11 @@ LICENSE = "MIT"
SECTION = "e/apps"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
CVSDATE = "${PV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/e \
file://fix-configure.patch;patch=1 \
- file://fudge_screen_edges_for_menu.patch;patch=1"
+ file://add-menu-autoscroll-options.patch;patch=1"
S = "${WORKDIR}/e"
inherit autotools
diff --git a/packages/e17/e17genmenu_2.0.2.bb b/packages/e17/e17genmenu_2.0.2.bb
new file mode 100644
index 0000000000..39a12319f8
--- /dev/null
+++ b/packages/e17/e17genmenu_2.0.2.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Convert Gnome or KDE menus to e17 menus"
+SECTION = "e/utils"
+DEPENDS = "e virtual/ecore virtual/evas eet engrave"
+LICENSE = "MIT"
+HOMEPAGE = "http://sourceforge.net/projects/e17genmenu"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+PR = "r0"
+
+export EET_CONFIG = "${STAGING_BINDIR}/eet-config"
+export EVAS_CONFIG = "${STAGING_BINDIR}/evas-config"
+export ECORE_CONFIG = "${STAGING_BINDIR}/ecore-config"
+export ENGRAVE_CONFIG = "${STAGING_BINDIR}/engrave-config"
+export ENLIGHTENMENT_CONFIG = "${STAGING_BINDIR}/enlightenment-config"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/e17genmenu/e17genmenu-2.0.2.tar.gz"
+
+do_configure_prepend() {
+ find -type f | xargs sed -i 's:share/icons/%s/48x48/apps:share/pixmaps:'
+ find -type f | xargs sed -i 's:share/icons/hicolor/48x48/apps:share/pixmaps:'
+}
+
+inherit autotools
diff --git a/packages/e17/eclair_20050810.bb b/packages/e17/eclair_20050810.bb
index ba1e8fb10d..62385e141c 100644
--- a/packages/e17/eclair_20050810.bb
+++ b/packages/e17/eclair_20050810.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Eclair is the E17 multi media player"
SECTION = "e/apps"
-DEPENDS = "freetype eet virtual/evas virtual/ecore embryo virtual/imlib2 edje-native edje emotion libxml2 sqlite3 taglibc"
+DEPENDS = "evas-x11 ecore-x11 embryo imlib2-x11 edje-native edje libxine-x11 emotion esmart libxml2 sqlite3 taglibc"
LICENSE = "MIT"
HOMEPAGE = "http://www.enlightenment.org"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
@@ -12,8 +12,6 @@ S = "${WORKDIR}/eclair"
inherit autotools
-BROKEN = "1"
-
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc"
FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir} ${sbindir}"
diff --git a/packages/e17/engage/.mtn2git_empty b/packages/e17/engage/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/e17/engage/.mtn2git_empty
diff --git a/packages/e17/engage/no-local-includes.patch b/packages/e17/engage/no-local-includes.patch
new file mode 100644
index 0000000000..09cc8da98d
--- /dev/null
+++ b/packages/e17/engage/no-local-includes.patch
@@ -0,0 +1,17 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- engage/src/module/Makefile.am~no-local-includes
++++ engage/src/module/Makefile.am
+@@ -10,8 +10,7 @@
+
+ # the module .so file
+ INCLUDES = -I. \
+- -I$(top_srcdir) \
+- -I$(includedir) \
++ -I$(top_srcdir) \
+ @e_cflags@
+ pkgdir = @e_modules@/engage/$(MODULE_ARCH)
+ pkg_LTLIBRARIES = module.la
diff --git a/packages/e17/engage_20050810.bb b/packages/e17/engage_20050810.bb
index e8f9467239..f12d7d2605 100644
--- a/packages/e17/engage_20050810.bb
+++ b/packages/e17/engage_20050810.bb
@@ -1,11 +1,12 @@
DESCRIPTION = "Engage is the E17 icon dock"
-DEPENDS = "esmart virtual/imlib2 edje virtual/ecore virtual/evas ewl e-wm"
+DEPENDS = "evas-x11 ecore-x11 esmart imlib2-x11 edje ewl e"
LICENSE = "MIT"
-SECTION = "e"
+SECTION = "e/apps"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
-PR = "r0"
+PR = "r1"
-SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=misc/engage"
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=misc/engage \
+ file://no-local-includes.patch;patch=1"
S = "${WORKDIR}/engage"
inherit autotools pkgconfig binconfig
diff --git a/packages/e17/entice_20050810.bb b/packages/e17/entice_20050810.bb
index 667d3f4da8..094944ead4 100644
--- a/packages/e17/entice_20050810.bb
+++ b/packages/e17/entice_20050810.bb
@@ -1,12 +1,12 @@
DESCRIPTION = "Entice is the E17 picture viewer"
SECTION = "e/apps"
# can also depend on GIMP for editing
-DEPENDS = "virtual/evas edb virtual/ecore edje"
+DEPENDS = "edb evas-x11 ecore-x11 edje epsilon esmart"
LICENSE = "MIT"
HOMEPAGE = "http://www.enlightenment.org"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
CVSDATE = "${PV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/entice"
S = "${WORKDIR}/entice"
diff --git a/packages/e17/entrance/Sessions/.mtn2git_empty b/packages/e17/entrance/Sessions/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/e17/entrance/Sessions/.mtn2git_empty
diff --git a/packages/e17/entrance/Sessions/Enlightenment b/packages/e17/entrance/Sessions/Enlightenment
new file mode 100644
index 0000000000..4d33bbb2e9
--- /dev/null
+++ b/packages/e17/entrance/Sessions/Enlightenment
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+enlightenment
+
diff --git a/packages/e17/entrance/Sessions/Failsafe b/packages/e17/entrance/Sessions/Failsafe
new file mode 100644
index 0000000000..cf4fcced12
--- /dev/null
+++ b/packages/e17/entrance/Sessions/Failsafe
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+rxvt \ No newline at end of file
diff --git a/packages/e17/entrance/Xinit.d/.mtn2git_empty b/packages/e17/entrance/Xinit.d/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/e17/entrance/Xinit.d/.mtn2git_empty
diff --git a/packages/e17/entrance/Xinit.d/50-calibrate b/packages/e17/entrance/Xinit.d/50-calibrate
new file mode 100644
index 0000000000..922b335c85
--- /dev/null
+++ b/packages/e17/entrance/Xinit.d/50-calibrate
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if ! test -e /etc/pointercal
+then
+ xtscal
+fi
+
diff --git a/packages/e17/entrance/Xinit.d/99-Entrance b/packages/e17/entrance/Xinit.d/99-Entrance
new file mode 100644
index 0000000000..297cc909fe
--- /dev/null
+++ b/packages/e17/entrance/Xinit.d/99-Entrance
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+entrance
+
diff --git a/packages/e17/entrance/config-db.patch b/packages/e17/entrance/config-db.patch
index 5e965057ba..874231b95b 100644
--- a/packages/e17/entrance/config-db.patch
+++ b/packages/e17/entrance/config-db.patch
@@ -1,5 +1,5 @@
---- entrance/data/config/build_config.sh.in~ 2005-08-13 02:56:11.000000000 -0700
-+++ entrance/data/config/build_config.sh.in 2005-08-13 02:56:35.000000000 -0700
+--- entrance/data/config/build_config.sh.in~ 2005-08-15 23:24:39.000000000 -0700
++++ entrance/data/config/build_config.sh.in 2005-08-15 23:25:15.000000000 -0700
@@ -3,7 +3,7 @@
rm -f $DB
@@ -9,7 +9,16 @@
# uncomment the below to enable experimental OpenGL hardware acceleration
#edb_ed $DB add /entrance/engine int 1
-@@ -25,25 +25,25 @@
+@@ -18,30 +18,30 @@
+ #edb_ed $DB add /entrance/fonts/0/str str "/usr/share/fonts/truetype/"
+ #edb_ed $DB add /entrance/fonts/1/str str "/usr/X11R6/lib/X11/fonts/Truetype/"
+ edb_ed $DB add /entrance/greeting/before str "Welcome to "
+-edb_ed $DB add /entrance/greeting/after str ""
++edb_ed $DB add /entrance/greeting/after str " e17/OE"
+ edb_ed $DB add /entrance/session/count int 8
+-edb_ed $DB add /entrance/session/0/session str "default"
++edb_ed $DB add /entrance/session/0/session str "/etc/X11/Sessions/Default"
+ edb_ed $DB add /entrance/session/0/title str "Default"
edb_ed $DB add /entrance/session/0/icon str "default.png"
edb_ed $DB add /entrance/session/1/icon str "enlightenment.png"
edb_ed $DB add /entrance/session/1/title str "Enlightenment"
@@ -30,27 +39,23 @@
-edb_ed $DB add /entrance/session/6/title str "XFce"
-edb_ed $DB add /entrance/session/6/icon str "xfce.png"
-edb_ed $DB add /entrance/session/7/session str "failsafe"
--edb_ed $DB add /entrance/session/7/title str "Failsafe"
--edb_ed $DB add /entrance/session/7/icon str "failsafe.png"
-+edb_ed $DB add /entrance/session/1/session str "/etc/X11/Session/Enlightenment"
-+#edb_ed $DB add /entrance/session/2/session str "kde"
-+#edb_ed $DB add /entrance/session/2/title str "KDE"
-+#edb_ed $DB add /entrance/session/2/icon str "kde.png"
-+edb_ed $DB add /entrance/session/2/session str "/etc/X11/Session/GPE"
-+edb_ed $DB add /entrance/session/2/title str "GPE"
-+edb_ed $DB add /entrance/session/2/icon str "gnome.png"
-+#edb_ed $DB add /entrance/session/4/session str "blackbox"
-+#edb_ed $DB add /entrance/session/4/title str "Blackbox"
-+#edb_ed $DB add /entrance/session/4/icon str "blackbox.png"
-+#edb_ed $DB add /entrance/session/5/session str "sawfish"
-+#edb_ed $DB add /entrance/session/5/title str "Sawfish"
-+#edb_ed $DB add /entrance/session/5/icon str "default.png"
-+#edb_ed $DB add /entrance/session/6/session str "xfce"
-+#edb_ed $DB add /entrance/session/6/title str "XFce"
-+#edb_ed $DB add /entrance/session/6/icon str "xfce.png"
-+edb_ed $DB add /entrance/session/3/session str "/etc/X11/Session/Failsafe"
-+edb_ed $DB add /entrance/session/3/title str "Failsafe"
-+edb_ed $DB add /entrance/session/3/icon str "failsafe.png"
++edb_ed $DB add /entrance/session/2/session str "/etc/X11/Sessions/Enlightenment"
++edb_ed $DB add /entrance/session/2/icon str "enlightenment.png"
++edb_ed $DB add /entrance/session/2/title str "Enlightenment"
++edb_ed $DB add /entrance/session/3/session str "/etc/X11/Sessions/Enlightenment"
++edb_ed $DB add /entrance/session/3/icon str "enlightenment.png"
++edb_ed $DB add /entrance/session/3/title str "Enlightenment"
++edb_ed $DB add /entrance/session/4/session str "/etc/X11/Sessions/Enlightenment"
++edb_ed $DB add /entrance/session/4/icon str "enlightenment.png"
++edb_ed $DB add /entrance/session/4/title str "Enlightenment"
++edb_ed $DB add /entrance/session/5/session str "/etc/X11/Sessions/Enlightenment"
++edb_ed $DB add /entrance/session/5/icon str "enlightenment.png"
++edb_ed $DB add /entrance/session/5/title str "Enlightenment"
++edb_ed $DB add /entrance/session/6/session str "/etc/X11/Sessions/Enlightenment"
++edb_ed $DB add /entrance/session/6/icon str "enlightenment.png"
++edb_ed $DB add /entrance/session/6/title str "Enlightenment"
++edb_ed $DB add /entrance/session/1/session str "/etc/X11/Sessions/Enlightenment"
++edb_ed $DB add /entrance/session/7/session str "/etc/X11/Sessions/Failsafe"
+ edb_ed $DB add /entrance/session/7/title str "Failsafe"
+ edb_ed $DB add /entrance/session/7/icon str "failsafe.png"
edb_ed $DB add /entrance/system/reboot int 1
- edb_ed $DB add /entrance/system/halt int 1
- edb_ed $DB add /entrance/user/remember int 1
diff --git a/packages/e17/entrance/longer-sleep.patch b/packages/e17/entrance/longer-sleep.patch
deleted file mode 100644
index 66ad220de2..0000000000
--- a/packages/e17/entrance/longer-sleep.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- entrance/src/client/entrance_session.c.~1.71.~ 2005-05-28 02:31:14.000000000 -0700
-+++ entrance/src/client/entrance_session.c 2005-08-07 13:39:35.000000000 -0700
-@@ -454,7 +454,7 @@
- shell = strdup("/bin/sh");
- /* this bypasses a race condition where entrance loses its x
- connection before the wm gets it and x goes and resets itself */
-- sleep(10);
-+ sleep(60);
- /*
- * FIXME These should be called!
- ecore_x_shutdown();
diff --git a/packages/e17/entrance/run-Xinit.patch b/packages/e17/entrance/run-Xinit.patch
new file mode 100644
index 0000000000..1d6c2307f7
--- /dev/null
+++ b/packages/e17/entrance/run-Xinit.patch
@@ -0,0 +1,17 @@
+--- entrance/src/daemon/entrance_wrapper.in.~1.1.~ 2003-01-31 13:57:06.000000000 -0800
++++ entrance/src/daemon/entrance_wrapper.in 2005-08-15 20:13:57.000000000 -0700
+@@ -5,8 +5,13 @@
+
+ test -f /etc/profile && . /etc/profile
+
++if [ -x /etc/X11/Xinit.d/99gpe-login ]; then
++ chmod -x /etc/X11/Xinit.d/99gpe-login
++fi
++
++/etc/X11/Xinit
++
+ exec @prefix@/bin/entrance "$@"
+
+ #fallback
+ exec entrance "$@"
+-
diff --git a/packages/e17/entrance/use-bash.patch b/packages/e17/entrance/use-bash.patch
new file mode 100644
index 0000000000..4d3b2f4aae
--- /dev/null
+++ b/packages/e17/entrance/use-bash.patch
@@ -0,0 +1,11 @@
+--- entrance/src/client/entrance_session.c.~1.71.~ 2005-05-28 02:31:14.000000000 -0700
++++ entrance/src/client/entrance_session.c 2005-08-15 21:45:53.000000000 -0700
+@@ -451,7 +451,7 @@
+ (int) pid);
+ }
+ _entrance_session_user_list_fix(e);
+- shell = strdup("/bin/sh");
++ shell = strdup("/bin/bash");
+ /* this bypasses a race condition where entrance loses its x
+ connection before the wm gets it and x goes and resets itself */
+ sleep(10);
diff --git a/packages/e17/entrance_20050810.bb b/packages/e17/entrance_20050810.bb
index 251698c233..af11e07fd5 100644
--- a/packages/e17/entrance_20050810.bb
+++ b/packages/e17/entrance_20050810.bb
@@ -2,18 +2,22 @@ DESCRIPTION = "Entrace is the Enlightenment login manager"
SECTION = "e/apps"
LICENSE = "MIT"
# can also use pam and crypt
-DEPENDS = "edb evas-x11 ecore-x11 edje esmart"
-RDEPENDS += "bash"
+DEPENDS = "edb evas-x11 ecore-x11 edje esmart gpe-dm"
+RDEPENDS += "bash gpe-dm"
HOMEPAGE = "http://www.enlightenment.org"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
CVSDATE = "${PV}"
-PR = "r0"
+PR = "r2"
SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/enlightenment;module=e17/apps/entrance \
- file://longer-sleep.patch;patch=1 \
file://Xserver.patch;patch=1 \
file://config-db.patch;patch=1 \
- file://allow-missing-xsession.patch;patch=1"
+ file://allow-missing-xsession.patch;patch=1 \
+ file://run-Xinit.patch;patch=1 \
+ file://use-bash.patch;patch=1 \
+ file://Xinit.d \
+ file://Sessions"
+
S = "${WORKDIR}/entrance"
inherit autotools
@@ -21,4 +25,14 @@ inherit autotools
EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
--with-xsession=/etc/X11/Xsession"
-FILES += "${datadir}" \ No newline at end of file
+FILES += "${datadir}"
+
+do_install_append() {
+ install -d ${D}/etc/X11/Xinit.d
+ install -d ${D}/etc/X11/Xsession.d
+ install -d ${D}/etc/X11/Sessions
+
+ install -m 755 ${WORKDIR}/Xinit.d/* ${D}/etc/X11/Xinit.d
+ install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
+
+}
diff --git a/packages/e17/examine_20050810.bb b/packages/e17/examine_20050810.bb
index 6e79fd946f..244bf2bcaf 100644
--- a/packages/e17/examine_20050810.bb
+++ b/packages/e17/examine_20050810.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "examine, the program configurator"
DEPENDS = "virtual/ecore ewl"
LICENSE = "MIT"
-SECTION = "e"
+SECTION = "e/apps"
MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
PR = "r0"
CVSDATE = "${PV}"