summaryrefslogtreecommitdiff
path: root/packages/e17/evidence_20050926.bb
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-09-30 17:59:20 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-30 17:59:20 +0000
commit7e5e0be1af62584244662daa1989ffd8206c7298 (patch)
tree6eade7dca695f1668a509a7debde9aae887b9ff0 /packages/e17/evidence_20050926.bb
parent206647fb6ccf68137a2793c913053579f4553244 (diff)
e17, efl: major upgrade to newer versions
- Upgraded shapshot-based packages to newest released snapshots - Upgraded CVS-based packages to use a newer date - Moved e and e-wm to use snapshots as a default instead of CVS - Updated patches to work with newer versions - Added patches to fix problems introduced in newer versions - Added a patch to disable the splash for e-wm (causes a segfault) - entrance now uses ecore_config instead of edb - Added pulling of m4 directories for a few packages and running of aclocal due to autotools problems - elitaire currently does not compile, removed from e-image
Diffstat (limited to 'packages/e17/evidence_20050926.bb')
-rw-r--r--packages/e17/evidence_20050926.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/packages/e17/evidence_20050926.bb b/packages/e17/evidence_20050926.bb
new file mode 100644
index 0000000000..0950b590c6
--- /dev/null
+++ b/packages/e17/evidence_20050926.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "evidence, an enlightenemt file manager"
+LICENSE = "GPL"
+SECTION = "e"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+# can support dbus, avifile, libmpeg3
+DEPENDS = "pkgconfig gtk+ glib-2.0 ecore-x11 evas-x11 edb eet edje imlib2-x11 libpng epeg jpeg pcre curl taglib libvorbis libogg libxine-x11 emotion freetype"
+RDEPENDS += "examine"
+PR = "r0"
+CVSDATE = "${PV}"
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/evidence;module=evidence"
+S = "${WORKDIR}/evidence"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
+ --enable-ecore \
+ --enable-ecore-ipc \
+ --enable-canvas-evas2 \
+ --enable-edje \
+ --enable-x \
+ --enable-tree-view \
+ --enable-icon-view \
+ --enable-browser-view \
+ --with-libxine=${STAGING_LIBDIR}"
+
+do_prepsources () {
+ make clean distclean || true
+}
+addtask prepsources after do_fetch before do_unpack
+
+do_compile_prepend() {
+ sed -i 's:LDFLAGS = :LDFLAGS = -L${STAGING_LIBDIR} :' ${S}/src/providers/vorbis/Makefile
+}
+
+export EET_CONFIG = "${STAGING_BINDIR}/eet-config"
+export EVAS_CONFIG = "${STAGING_BINDIR}/evas-config"
+export ECORE_CONFIG = "${STAGING_BINDIR}/ecore-config"
+export EMBRYO_CONFIG = "${STAGING_BINDIR}/embryo-config"
+export EDJE_CONFIG = "${STAGING_BINDIR}/edje-config"
+
+FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} /etc/* /usr/sbin/*"
+
+inherit autotools pkgconfig binconfig